Bug Hunting Session
Bug 112823 - Not Possible Insert Formula into shapes in Write
Summary: Not Possible Insert Formula into shapes in Write
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OLE-Object-Interoperability
  Show dependency treegraph
 
Reported: 2017-10-02 12:20 UTC by Ramon Tavarez
Modified: 2017-10-03 21:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ramon Tavarez 2017-10-02 12:20:32 UTC
WRITER:
1.- Insert a  basic shape in Writer: INSERT ->  SHAPE -> (any oprion)
2.- Insert a formula : INSERT ->  OBJECT ->  FORMULA   (this option is not available!, grayed)

DRAW:

1.- Insert a  basic shape in Writer: INSERT ->  SHAPE -> (any oprion)
2.- Insert a formula : INSERT ->  OBJECT ->  FORMULA   (this option is available!,  but places the  formula object outside the shape)
Comment 1 Dieter Praas 2017-10-02 16:38:09 UTC
I can reproduce the steps for Writer, but I can't reproduce it for Draw, because the first step is not possible for me (there is no shape entry in the Insert-menu).

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 465092047d5fa6ec6dd369372e712d76554570ff
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-26_23:16:01
Locale: de-DE (de_DE); Calc: group
Comment 2 Ramon Tavarez 2017-10-03 12:54:15 UTC
(In reply to Dieter Praas from comment #1)
> I can reproduce the steps for Writer, but I can't reproduce it for Draw,
> because the first step is not possible for me (there is no shape entry in
> the Insert-menu).
> 
> Version: 6.0.0.0.alpha0+ (x64)
> Build ID: 465092047d5fa6ec6dd369372e712d76554570ff
> CPU threads: 4; OS: Windows 6.19; UI render: GL; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-26_23:16:01
> Locale: de-DE (de_DE); Calc: group

Hi, You're right. I forgot that in Draw  the shapes are inserted via the toolbars.

The fact is that after the shape we can insert a formula with Math, thing that we can't do with Writer.
Comment 3 Ramon Tavarez 2017-10-03 13:00:37 UTC Comment hidden (no-value)
Comment 4 Ramon Tavarez 2017-10-03 13:01:06 UTC Comment hidden (obsolete)
Comment 5 Dieter Praas 2017-10-03 20:46:34 UTC
Reproducible with LO 6.0.0.0

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 465092047d5fa6ec6dd369372e712d76554570ff
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-26_23:16:01
Locale: de-DE (de_DE); Calc: group
Comment 6 V Stuart Foote 2017-10-03 21:27:43 UTC
Clearly NAB, if you need a Math formula object overlaid on a Draw object on Writer canvas, just place the object with Insert -> Object -> Formula and anchor both to Page or Paragraph as needed. However, they can not be linked or grouped (other than sharing an anchor point).

Or you can work within a Frame, dropping Draw objects and Math OLE formulas into a Frame on Writer canvas--anchor the objects to Frame and adjust the layering. The Frame will then move.

Either way Draw objects and Math Formula OLE objects are simply handled differently between the Draw canvas or when added to the Writer canvas directly or into a Frame object.

Suppose a Writer enhancement to do so, but not clear there is much of a requirement for Draw canvas handling in Writer context, see also bug 104327 was one such.

A lot would depend on limitations of ODF Text Document to hold the OLE Math formula and Draw shapes consistently.