Bug Hunting Session
Bug 112824 - Line spacing problem of Futura-Book
Summary: Line spacing problem of Futura-Book
Status: RESOLVED DUPLICATE of bug 107605
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering Paragraph-Line-Spacing Cell-Line-Spacing
  Show dependency treegraph
 
Reported: 2017-10-02 13:19 UTC by Thomas Lendo
Modified: 2017-10-03 21:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot: comparison of Futura-Book in Writer, LibO 5.1 and 6.0.0.0.alpha0+ (318.33 KB, image/png)
2017-10-02 13:19 UTC, Thomas Lendo
Details
Example file with Futura-Book and some paragraph styles (24.42 KB, application/vnd.oasis.opendocument.text)
2017-10-02 13:22 UTC, Thomas Lendo
Details
fonttools output for Futura-Book.ttf (2.19 KB, application/x-font-ttx)
2017-10-03 20:44 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-10-02 13:19:44 UTC
Created attachment 136688 [details]
Screenshot: comparison of Futura-Book in Writer, LibO 5.1 and 6.0.0.0.alpha0+

Due to bug 112558 comment 10 I report the bad behavior of proprietary font "Futura-Book" since activating of the new harfbuzz rendering.

Attachment 136522 [details] (screenshot of Calc-Writer font comparison) and attachment 136523 [details] (zip archive with resources for Calc-Writer font comparison) shows the bug in comparison to other fonts.

I'll attach a new screenshot and the odt file. If there is a question because of the font itself as I'm not allowed to insert it in the file, please ask me privately.

The example shows the "Futura-Book" font and 12pt font size:
* Default paragraph style with single line spacing.
* Text Body with 120 % proportional line spacing.
* Heading 5 with single line spacing (not in the screenshot).
* Caption paragraph style with single line spacing.
* Endnote with single line spacing.
(All default attributes without a user change.)

All lines but the last in a paragraph only are readable with line spacing options
* Double line spacing,
* At least 12 pt
* Leading 6 pt
* Fixed 13 pt
Comment 1 Thomas Lendo 2017-10-02 13:22:42 UTC
Created attachment 136689 [details]
Example file with Futura-Book and some paragraph styles
Comment 2 Xisco Faulí 2017-10-02 15:44:08 UTC
At a first glance, it looks like similar to bug 107605 or bug 107888.
@Khaled, could you please confirm ?
Comment 3 Khaled Hosny 2017-10-02 21:09:33 UTC
(In reply to Xisco Faulí from comment #2)
> At a first glance, it looks like similar to bug 107605 or bug 107888.
> @Khaled, could you please confirm ?

Probably yes, can’t be sure without checking the font itself.
Comment 4 Xisco Faulí 2017-10-02 21:16:34 UTC
(In reply to Khaled Hosny from comment #3)
> (In reply to Xisco Faulí from comment #2)
> > At a first glance, it looks like similar to bug 107605 or bug 107888.
> > @Khaled, could you please confirm ?
> 
> Probably yes, can’t be sure without checking the font itself.

Is there any place where it's explained how to check it ?
Comment 5 Khaled Hosny 2017-10-03 10:38:09 UTC
(In reply to Xisco Faulí from comment #4)
> (In reply to Khaled Hosny from comment #3)
> > (In reply to Xisco Faulí from comment #2)
> > > At a first glance, it looks like similar to bug 107605 or bug 107888.
> > > @Khaled, could you please confirm ?
> > 
> > Probably yes, can’t be sure without checking the font itself.
> 
> Is there any place where it's explained how to check it ?

AFAIK, no. But if one has access to the font and can install fonttools, executing `ttx -t hhea -t OS/2 font.ttf` and attaching the output here should be enough.
Comment 6 Xisco Faulí 2017-10-03 10:40:31 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2017-10-03 20:44:08 UTC
Created attachment 136746 [details]
fonttools output for Futura-Book.ttf

Thanks, Khaled and Xisco. Attached you'll find the output file.
Comment 8 Xisco Faulí 2017-10-03 21:01:04 UTC
(In reply to Thomas Lendo from comment #7)
> Created attachment 136746 [details]
> fonttools output for Futura-Book.ttf
> 
> Thanks, Khaled and Xisco. Attached you'll find the output file.

@Khaled, could you please take a look ?
Comment 9 Khaled Hosny 2017-10-03 21:13:05 UTC
Should be fixed with the same fix for bug 107605.

*** This bug has been marked as a duplicate of bug 107605 ***