Bug 112936 - Pivot table: LO created XLSX file makes Excel to crash
Summary: Pivot table: LO created XLSX file makes Excel to crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.0.0
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Corrupted Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2017-10-06 13:12 UTC by Tamás Zolnai
Modified: 2019-04-30 13:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Simple pivot table with a field named "DATA" (11.75 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-10-06 13:12 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-10-06 13:12:20 UTC
Description:
Check the attached test document. It was created in MS Excel and contains a simple pivot table. If I open it in Calc and save back to an XLSX file than MSO opens it, but when I try to refresh the pivot table it crashes.
After some testing I found out that this is because of the field called "DATA". This "DATA" name might collide with some internally used name. I would guess something like that. If I change it to "DATA1" in the source range and refesh the table, then roundtriping in Calc will not lead to this issue.

Steps to Reproduce:
1. Open attached test XLSX in Calc
2. Save it back to an XLSX file
3. Open in Excel and refresh the table (right click on pivot table -> refresh)

Actual Results:  
Excel crashes.

Expected Results:
Excel should not crash on the roundtripped document.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 Tamás Zolnai 2017-10-06 13:12:43 UTC
Created attachment 136802 [details]
Simple pivot table with a field named "DATA"
Comment 2 Commit Notification 2017-10-06 19:00:21 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bab595df78bd05a45f92aa15dca058f27b86d5be

tdf#112936: Pivot table: LO created XLSX file makes Excel to crash

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.