Download it now!
Bug 113020 - EDITING: Text alignment in some templates (for example) Alizarin not working for some textboxes
Summary: EDITING: Text alignment in some templates (for example) Alizarin not working ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.6
Keywords:
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2017-10-09 15:51 UTC by Telesto
Modified: 2019-02-28 02:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-09 15:51:30 UTC
Description:
EDITING: Text alignment in the Alizarin template not working for some textboxes

Steps to Reproduce:
1. Open Impress
2. Choose the Alizarin template
3. Select the Click To Add Title textbox and type something into it
4. Set the alignment to Center

Actual Results:  
No effect

Expected Results:
Should be working


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-07_01:04:25
Locale: nl-NL (nl_NL); Calc: CL

and in 5.4


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Aschalew 2017-10-13 07:38:17 UTC
Doesn't Reproduce

Windows 10 (x64)

LibreOffice:
   Version: 5.4.2.2 (x64)
   Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
   CPU threads: 8; OS: Windows 6.19; UI render: default; 
   Locale: en-US (en_US); Calc: group

Yes! It seems something like a default value. I tried it on LO 5.4.2.2 and it doesn't have any effect on text alignment to 'Click to add Title'
Comment 2 Aschalew 2017-10-13 07:59:58 UTC
(In reply to Aschalew from comment #1)
Reproduce
> 
> Windows 10 (x64)
> 
> LibreOffice:
>    Version: 5.4.2.2 (x64)
>    Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
>    CPU threads: 8; OS: Windows 6.19; UI render: default; 
>    Locale: en-US (en_US); Calc: group
> 
> Yes! It seems something like a default value. I tried it on LO 5.4.2.2 and
> it doesn't have any effect on text alignment to 'Click to add Title'
Comment 3 Buovjaga 2017-11-04 19:12:04 UTC
NEW per comment 2
Comment 4 QA Administrators 2018-11-05 03:43:37 UTC Comment hidden (obsolete)
Comment 5 Aron Budea 2019-01-29 22:45:36 UTC
Still in 6.3.0.0.alpha0+ (fdc91f7493171ae600ecb293ad380df5fa77a277), and already existed in 3.3.0, when checked with a file generated in a later version. If the file itself is broken, then it's a different case.
Comment 6 Cosmin Saveanu 2019-02-08 11:39:50 UTC
This problem is probably due to a property of text boxes called 'anchor' well described here:

https://ask.libreoffice.org/en/question/26909/does-text-centering-work-correctly-in-impress/

It is likely that the title textbox lacks the 'Full width' option.

Related to bug 58492:
https://bugs.documentfoundation.org/show_bug.cgi?id=58492
Comment 7 Laurent BP 2019-02-13 15:54:11 UTC
https://opengrok.libreoffice.org/xref/core/extras/source/templates/presnt/Alizarin/styles.xml?r=659acfbb#286

draw:textarea-horizontal-align="left" ==>
draw:textarea-horizontal-align="justify"
Comment 8 Commit Notification 2019-02-15 21:38:58 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/802e77dd4fe0192942a493b4c83e2c8b31c210c2%5E%21

tdf#113020 Change horizontal-align to justify

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-02-18 15:42:20 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/7b9f8fdee94f74107f5d6fb1fb94fab9dbb4047c%5E%21

tdf#113020 Change horizontal-align to justify

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-02-19 18:13:01 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/e9b776dd2006c05d9e19ec8fb5870cb91f37b981%5E%21

tdf#113020 Change horizontal-align to justify

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-02-26 12:43:29 UTC
Laurent BP committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-1":

https://git.libreoffice.org/core/+/4e6a5078e68aa468a049969d146593c5e971a11d%5E%21

tdf#113020 Change horizontal-align to justify

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.