Bug 113024 - Unable to open file in a read only mounted directory
Summary: Unable to open file in a read only mounted directory
Status: RESOLVED DUPLICATE of bug 115383
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2017-10-09 18:32 UTC by Laurent BP
Modified: 2018-02-23 16:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect details, -till54 repository (2.48 KB, text/plain)
2017-12-11 21:18 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2017-10-09 18:32:29 UTC
Description:
If directory is mounted in read only mode, file cannot be directly open.

Steps to Reproduce:
1. In terminal, create two directories:$ mkdir A B
2. create a document directory A/doc.odt
3. mount directory A in directory B in read only:$ mount -Bo ro A B
4. in LibreOffice, try to open B/doc.odt (do not check "Read-only" checkbox)

Actual Results:  
Open dialog closed, but nothing happen on my LibO 5.4.2.2 (Ubuntu 16.04). A user reported a crash with LibO 5.4.1.2 but I could not reproduced.

Expected Results:
In LibO 5.3.6.1, B/doc.odt is open in read-only mode.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
If you check "Read-only" in Open dialog, then B/doc.odt is correctly opened in read only mode.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Laurent BP 2017-10-09 18:34:37 UTC
On fresh master, I got "General input/output error while accessing /home/.../B/doc.odt." error message.
Comment 2 Serge Smeesters 2017-10-19 10:11:23 UTC
Toujours présent, le bug dans la version ici utilisé :

 Version: 5.4.2.2
 Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo1
 Threads CPU : 3; OS : Linux 4.10; UI Render : par défaut; VCL : gtk2;
 Locale : fr-BE (fr_BE.UTF-8); Calc: group

Via ppa:libreoffice/ppa sous GNU/Linux Mint 18.2 MATE 64 bits.

Merci aux développeurs de prendre ceci très au sérieux.

C'est vraiment un très gros problème vis-à-vis de l'utilisation de système de
sauvegardes (“backup” en anglais).

Bien souvent, l'accès aux dossiers et fichiers sauvegardés est en lecture seule
mais les stat's sur les dossiers et fichiers ne l'informe pas forcément aux
logiciels (LibrOffice).
Comment 3 TBeholder 2017-10-21 01:35:08 UTC
5.1.6.2 (whether from command line or GUI):
if it can't write to the file - opens in read-only,
if it can write to the file, but not that directory - opens for r/w and actually saves, but without creating a lock file.
Comment 4 Terrence Enger 2017-12-11 21:18:39 UTC
Created attachment 138379 [details]
bibisect details, -till54 repository

Working in the -till54 bibisect repository on debian-buster, I see
that the problem came into LO somewhere in the 21 commits to master:

          commit    date        s-h
          --------  ----------  --------
    good  c2e7bbd8  2017-05-14  b82c9439
    bad   b9f803f0  2017-05-15  8c0be54a

I am removing keyword bibisectRequest and adding bibisected.
Comment 5 rpr 2018-02-23 16:12:47 UTC
I see this issue on ver. 6.0.1.1 (tested on Ubuntu 16.04 LTS and 17.10).

It happens most notably when you try to open files on a read-only device (e.g. CD/DVD-ROM or a mounted ISO image).

LibreOffice reports the following error: "General input/output error while accessing <file path>".
Comment 6 Aron Budea 2018-02-23 16:30:44 UTC
Good news, this has been fixed (it was a small mixup), the fix will be part of the next update (6.0.2 and 5.4.6).

*** This bug has been marked as a duplicate of bug 115383 ***