Bug Hunting Session
Bug 113068 - In Slide Show, speckles (colored pixels) appear around text displayed on top of an image
Summary: In Slide Show, speckles (colored pixels) appear around text displayed on top ...
Status: RESOLVED DUPLICATE of bug 107090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-12 14:28 UTC by David F Smith
Modified: 2017-10-12 21:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Impress presentation that shows the speckle problem. (4.63 MB, application/vnd.oasis.opendocument.presentation)
2017-10-12 14:37 UTC, David F Smith
Details
Screen capture from Slide Show of first slide in example presentation under version 5.4.2.2. (158.89 KB, image/jpeg)
2017-10-12 14:40 UTC, David F Smith
Details
Screen capture from Slide Show of first slide in example presentation under version 5.3.6.1. (154.61 KB, image/jpeg)
2017-10-12 14:41 UTC, David F Smith
Details
Screen capture from Slide Show of first slide in example presentation under version 5.2.6.2. (152.21 KB, image/jpeg)
2017-10-12 14:43 UTC, David F Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David F Smith 2017-10-12 14:28:55 UTC
Description:
If text overlays an image (photo), then in Slide Show the characters of text may be surrounded by sprinkles of colored pixels.  These speckles fall mostly along horizontal and vertical lines; I speculate that they may be related to the edges of the jpeg blocks.

This problem exists in 5.3.6.1 and 5.4.2.2.  It does not exist in 5.2.6.2 and 5.2.2.2.  I have not tried any other versions.

I will attach a sample presentation file that shows the problem, along with a couple of screen captures that illustrate what I see.

Variations:
* The speckles appear for all of the fonts that I have tried, and for normal, bold, italic, and bold-italic versions of those fonts.
* Interestingly, the speckles do not appear for outline fonts.
* The appearance of the speckles, and their color, do not depend on the color of the text characters.
* The speckles depend on the "darkness" of the image.  If the text is over a white or nearly white area, there are no visible speckles.  They are conspicuous over a cloudy blue sky.  If the background is very dark and with much detail (like a forest scene), there may be speckles, but they won't be obvious.

Steps to Reproduce:
1. On a new slide, insert an image.  I used a jpeg photo, slightly compressed but still with high quality.  Enlarge the image if necessary to fill, or mostly fill, the slide.
2. Draw a rectangle over an appropriate area of the image.  ("Appropriate area" means not completely white, and not absolutely smooth and featureless, but still light enough to see speckles.) Set the fill pattern of the rectangle to None, so that the image underneath is completely visible.
3. Type some text into the rectangle.  Select all of the text and enlarge the point size to something big -- maybe 80 or more.  If desired, change the font or color.
4. Start the slide show.  In one of the affected versions, speckles should be visible around the text characters.

Actual Results:  
See screen captures, attached.

Expected Results:
No speckles.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 David F Smith 2017-10-12 14:37:11 UTC
Created attachment 136926 [details]
Impress presentation that shows the speckle problem.

In "Speckled text 2.odp", the first slide is a photo with a title in orange text.  In Slide Show, purple speckles appear around all of the characters.
The second slide is identical, except that part of the text is outline characters; in Slide Show, there are no speckles around those characters.
The third slide has a different image, different font, and different color, but purple speckles still appear in Slide Show.
The fourth slide has a sky color that is nearly white, and the text title overlays both the sky and the forested mountains.  In Slide Show, the speckles appear (and are not easy to see) only over the mountainsides, not over the sky.
Comment 2 David F Smith 2017-10-12 14:40:18 UTC
Created attachment 136927 [details]
Screen capture from Slide Show of first slide in example presentation under version 5.4.2.2.

Purple speckles are obvious around the orange text.
Comment 3 David F Smith 2017-10-12 14:41:58 UTC
Created attachment 136928 [details]
Screen capture from Slide Show of first slide in example presentation under version 5.3.6.1.

Purple speckles are obvious around the orange text.  Interestingly, they are not identical to the speckles in 5.4.2.2, even though the presentation file is exactly the same.
Comment 4 David F Smith 2017-10-12 14:43:03 UTC
Created attachment 136929 [details]
Screen capture from Slide Show of first slide in example presentation under version 5.2.6.2.

No speckles are visible.  (This is also true under 5.2.2.2.)
Comment 5 V Stuart Foote 2017-10-12 16:39:11 UTC
You don't list Windows version or Graphics card, nor the rendering mode you've tested the presentation in (OpenGL, GPU Hardware Accelerated, CPU only) but likely issue bug 107090

We've temporarily reverted from DirectWrite Direct2D rendering to GDI based rendering for Hardware Acceleration.

Please test with an 5.3.7.1 build ( http://dev-builds.libreoffice.org/pre-releases/win/ ) or current development master.
Comment 6 David F Smith 2017-10-12 20:17:10 UTC
My symptoms are quite different from bug 107090 -- cleanly formed text characters, but surrounded by scattered pixels if displayed over image -- but running under 5.3.7.1 fixed it, so I suspect you have it.

To answer your questions (apologies for omitting important info), I'm running Windows 10 Pro (10.0.15063), although LibreOffice Help About says OS Version Windows 6.2.  Under Graphics Output, "Use hardware acceleration" and "Use OpenGL for all rendering" are both checked. 

I'm happy to provide more info or do further testing.
Comment 7 David F Smith 2017-10-12 20:19:58 UTC
Sorry.  Graphics card is Intel HD Graphics.  This is a plain-vanilla system.
Comment 8 David F Smith 2017-10-12 20:29:53 UTC
I went back to 5.3.6.1.  Turning off "Use hardware acceleration" there fixed the problem.  Turning off "Use OpenGL" did not.

For what it's worth.
Comment 9 V Stuart Foote 2017-10-12 21:19:30 UTC
The "Use Hardware acceleration" and "Use OpenGL for all rendering" are mutually exclusive. Enabling one will disable the other (a UI glitch if the HA button shows checked when OpenGL is enabled).

So, it is working for you with OpenGL rendering, and also when HA is disabled (so just CPU rendering.

Thats a duplicate of bug 107090 -- poor quality rendering of the presentation canvas (bad lettering, and color artifacts like this).

Reverted in 5.3.7.1, and the 5.4.3.1 build as well as in current master.

*** This bug has been marked as a duplicate of bug 107090 ***
Comment 10 David F Smith 2017-10-12 21:51:22 UTC
Thanks for the explanation, and for quickly checking on my report.