Bug Hunting Session
Bug 113089 - Font selector box should filter on substrings
Summary: Font selector box should filter on substrings
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-13 08:13 UTC by Ole Tange
Modified: 2017-11-06 07:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ole Tange 2017-10-13 08:13:26 UTC
Description:
I have 100s of fonts on my system. It is really a bother to have to scroll to the relevant font and it is even worse to have to spell the full font name: Think 'Montserrat ExtraBold' when you also have 'Montserrat ExtraLight'.

What I propose is to use the input box above the dropdown as a filter:

When focus is in the textbox, the font list is automatically opened - you do not have to press the 'down' button. In the box you enter substrings delimited by space. In the dropdown you will only be shown fonts that match all of the substrings.

That means that I can select 'Montserrat ExtraBold' by entering: tse abo (For: Mon_tse_rrat Extr_abo_ld), then arrow down and enter to select it.

This is way faster than having to scroll through the whole list, and will also be helpful to people that need an 'ExtraBold' font for a heading, and want to see all the fonts they have available in 'ExtraBold'.


Additionally it would be nice if the dropdown was bigger, with multiple columns or at least resizable, so I can see more fonts. 

Steps to Reproduce:
For wishlist

Actual Results:  
For wishlist

Expected Results:
For wishlist


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36
Comment 1 Heiko Tietze 2017-11-04 15:00:19 UTC
Absolutely, there should be means to better deal with fonts. My approach is to delete everything from the system what is not ultimately needed. Not the best workaround ;-)

Let's keep things together and continue at bug 91130.

*** This bug has been marked as a duplicate of bug 91130 ***
Comment 2 Ole Tange 2017-11-06 07:56:34 UTC
>  My approach is to delete everything from the system what is not ultimately needed. Not the best workaround.

And impossible in an enterprise environment where the user does not have access to delete pre-installed fonts.