Bug 113137 - FILEOPEN ODT: File processing time has increased quite a bit
Summary: FILEOPEN ODT: File processing time has increased quite a bit
Status: RESOLVED DUPLICATE of bug 94184
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: VCL-Scheduler
  Show dependency treegraph
 
Reported: 2017-10-15 12:21 UTC by Telesto
Modified: 2017-10-15 21:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.81 KB, text/plain)
2017-10-15 12:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-15 12:21:17 UTC
Description:
File processing time has increased a lot

Steps to Reproduce:
1. Open Writer & disable automatic spell check
2. Open attachment 136963 [details] and monitor the time needed to fully load the document c.q. CPU usage drops to zero. In recent release the load time is split up by the commit identified here bug 113105 (but it's probably not the real cause)  

Actual Results:  
Load time has doubled

Expected Results:
The before before the commit


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-07_01:04:25
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-10-15 12:22:42 UTC
Created attachment 136987 [details]
Bibisect log

Bibisected to:

author	Michael Meeks <michael.meeks@collabora.com>	2015-06-10 11:08:00 (GMT)
committer	Michael Meeks <michael.meeks@collabora.com>	2015-06-10 16:27:20 (GMT)
commit	48c2815dd20cf20eeec8bb4e003000f4a3d13291 (patch)
tree	19596543beea4e4f56d1d06f429e575f596f0ad7
parent	ef4fd9c52f16e6d242f999dd87170e6cac07230d (diff)
tdf#91727 - Unwind non-dispatch of idle handlers.
This clobbers the functionality from commit:

    06d731428ef6cf93c7333e8228bfb6088853b52f

    make idle timers actually activate only when idle

Since now all rendering and re-sizing is done in idle handlers it
does effectively the opposite of what was intended. A better solution
would allow special-casing the processing of just rendering,
re-sizing and window management to spin for eg. progress bar
rendering.

Also add helpful debugging labels to the idle & timeouts.

Also cleanup the Idle vs. Scheduler handling.

Also ensure that starting an Idle triggers a mainloop wakeup.

Also add a unit test.
Comment 2 Xisco Faulí 2017-10-15 21:20:42 UTC
Same commit as in bug 94184.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 94184 ***
Comment 3 Xisco Faulí 2017-10-15 21:29:24 UTC
BTW,
I don't see any delay loading it in (without the automatic spell checker )

Version: 6.0.0.0.alpha0+
Build ID: 8eacd3be08bf6e1a97900624611822de9b00a379
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group