Bug 113191 - Add 21 and 42 in size list for CJK due to the typographic scale convention
Summary: Add 21 and 42 in size list for CJK due to the typographic scale convention
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium enhancement
Assignee: Julien Nabet
URL:
Whiteboard: target:7.4.0 target:7.3.1
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2017-10-17 15:04 UTC by Cheng-Chia Tseng
Modified: 2022-02-08 08:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cheng-Chia Tseng 2017-10-17 15:04:15 UTC
The typographic scale system inherited from the movable type system in CJK area uses 21 pt and 42 pt a lot.

Here are the information of the typographic scale system:

Japan
Set A: 一号 27.5 pt and 四号 13.75 pt
Set B (mostly used set): 初号 42 pt for title, 二号 21 pt for heading, 五号 10.5 pt for body text, and 七号 5.25 pt for ruby 
Set C: 三号 16 pt, 六号 8pt, and 八号 4pt


China
Set A: 一号 26 pt, 小一号 24 pt, 四号 14 pt and 小四号 12 pt
Set B (mostly used set): 初号 42 pt, and 小初号 36 pt for title; 二号 21 pt and 小二号 18 pt for heading; 五号 10.5 pt and 小五号 9 pt for body text; 七号 5.25 pt for ruby 
Set C: 三号 16 pt, 小三号 15 pt, 六号 8pt, 小六号 6.5 pt and 八号 4pt


Taiwan
Set A: 一號 27.5 pt, 四號 13.75 pt and 新四號 12 pt 
Set B (mostly used set): 初號 42 pt and 新五號四行 36 pt for title; 二号 21 pt for heading; 五號 10.5 pt and 新五號 9 pt for body text; 七號 5.25 pt for ruby 
Set C: 三號 16 pt, 六號 8pt, and 八號 4pt

The listed sizes of typpographic scale in LibreOffice are:
6, 7, 8, 9, 10, 10.5, 11, 12, 13, 14, 15, 16, 18, 20, 22, 24, 26, 28, 32, 36, 40, 44, 48, 54, 60, 66, 72, 80, 88, and 96 pt

Regardless of the etremely small sizes and those with fractions, the mostly used 21 pt and 42 pt size in CJK typographic scale systems are missing in the size list.

Reproducible: always

Steps to reproduce:
1. check the size list

Actual result:
1. the mostly used 21 pt and 42 pt sizes are missing in the size list

Expected result:
1. the mostly used 21 pt and 42 pt sizes should be listed in the size list
Comment 1 V Stuart Foote 2017-10-17 20:59:26 UTC
reasonable
Comment 2 Julien Nabet 2022-02-05 18:19:26 UTC
I submitted a patch here:
https://gerrit.libreoffice.org/c/core/+/129530

Heiko/Xisco: I put you in cc since I wouldn't like to trigger some pb from UX point of view.
Comment 3 Heiko Tietze 2022-02-07 08:30:04 UTC
Clear request, Stuart +1'ed... no objection from my side.
Comment 4 Commit Notification 2022-02-07 17:06:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ad9aa572594f04d2c498d087fb81b0fb215b8e7d

tdf#113191: Add 21 and 42 in size list for CJK for typographic scale convention

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2022-02-07 17:08:55 UTC
Patch waiting for review for 7.3 branch here:
https://gerrit.libreoffice.org/c/core/+/129609
Comment 6 Commit Notification 2022-02-08 08:34:51 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/68ad330086ac6ba02b6eefbd632c8517fcb27c5e

tdf#113191: Add 21 and 42 in size list for CJK for typographic scale convention

It will be available in 7.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.