Download it now!
Bug 113243 - Previews with white text is blank on white background
Summary: Previews with white text is blank on white background
Status: RESOLVED DUPLICATE of bug 115507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Styles-Preview Font-Preview
  Show dependency treegraph
 
Reported: 2017-10-18 20:31 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-07 09:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with dark theme (150.49 KB, image/png)
2017-10-19 11:19 UTC, Heiko Tietze
Details
how it looks in Word style window (33.58 KB, image/png)
2017-10-19 11:25 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-10-18 20:31:17 UTC
steps:
1. open attachment 137084 [details]
2. open style deck of sidebar
3. notice that there are blank entries in the list for 'Document Title' and 'Table Headings -- 11 pt'
4. select some text in the document
5. Format > Character
6. set font color to white in Font Effects tab
7. preview will be all white

Heiko, Stuart, Maxim: Quite sure something definitely would need to be done for the styles combobox and style deck, but does something also need to be done for the preview in the character dialog.

Version: 6.0.0.0.alpha0+
Build ID: 5ea1b4c336d1cad92dc18e7cf7e4b381396f448b
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Heiko Tietze 2017-10-19 06:49:59 UTC
Depends on your theme, with my Breeze Dark the white font looks pretty neat. Of course the issue is the same when font is defined as dark gray (automatic works well). I wouldn't do anything here (NAB).
Comment 2 Mohamed 2017-10-19 08:39:52 UTC
The issue is reproduced for the attached document, ‘Document Title’ and ‘Table Headings -- 11 pt’  text color is white so I couldn’t see it only when selecting the option. Also the using white color as text font color makes the selected characters invisible if the background is white also, even when selected I am not able to see the text.
Testing environment:
    • Operating system : Windows 8.1 Pro 64-bits.
    • LibreOffice : Version: 5.4.2.2
		Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
		CPU threads: 4; OS: Windows 6.2; UI render: default; 
		Locale: en-US (en_US); Calc: group

     And also on :
    • Operating system : Ubuntu 16.04.3 64-bits.
    • LibreOffice :Version: 5.4.2.2
		Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
		CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
		Locale: ja-JP (ja_JP.UTF-8); Calc: group
Comment 3 Heiko Tietze 2017-10-19 11:19:07 UTC
Created attachment 137111 [details]
Screenshot with dark theme
Comment 4 Yousuf Philips (jay) (retired) 2017-10-19 11:25:21 UTC
Created attachment 137112 [details]
how it looks in Word style window
Comment 5 QA Administrators 2018-11-05 03:43:21 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2018-11-05 08:10:29 UTC
We decided with a similar ticket to keep the current situation. Users who want to use a bright font on a white background do that intentionally. Those users are supposed to switch of "[x] Show Preview" in order to read the content.

@Thomas: You disagreed back then. Don't find the other ticket with the discussion, maybe you want to reopen or crosslink.
Comment 7 Thomas Lendo 2018-11-07 09:17:30 UTC
I will not reopen this bug but make it a dupe of bug 115507 (which also and already contains dupes that were created for character styles).

*** This bug has been marked as a duplicate of bug 115507 ***