Bug 113288 - Writer does not remember and not even keep the position of its window on the desktop
Summary: Writer does not remember and not even keep the position of its window on the ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2017-10-20 13:08 UTC by Christian Lehmann
Modified: 2019-10-31 15:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2017-10-20 13:08:43 UTC
Description:
On Ubuntu 16.04, my LibreOffice Writer window should occupy the vertical space between the upper and lower Ubuntu screen edges. It does not, however, attach reliably to these edges. Once I fixed it there, at an unsupervised moment, it slips down again by half a centimeter, so that the lower part of the window disappears below the screen. Same happens every time I open Writer.

Steps to Reproduce:
1. Click Writer symbol on Ubuntu 16.04 launcher.
2. Fix Writer window at upper and lower edge of Unity desktop.
3. Close Writer
4. Call Writer by again clicking launcher symbol.

Actual Results:  
Writer window is shifted to half a centimeter below the desired position, so that the lower part of the window disappears below the screen edge.

Expected Results:
It should have positioned the window at the exact position where Writer was closed.


Reproducible: Always

User Profile Reset: No

Additional Info:
This can even happen while the Writer window is open. However, I cannot tell how to reproduce the unwanted relocation.

Might there be some interference with Ubuntu desktop settings?


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Christian Lehmann 2017-10-21 09:04:56 UTC
Same happens with LibreOffice Base. Could it be that LibreOffice does not, in principle, remember the location of its windows?
Comment 2 Xisco Faulí 2017-10-21 15:20:25 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Christian Lehmann 2017-10-21 15:43:06 UTC
No; I chose "5.0 all versions" at the Version tab above because it wants the "earliest affected". Actually, I am working with LibreOffice 5.4.2.2.

And I can now add more precision:
1) The bug happens with every component of LibreOffice: Writer, Base, Calc, Impress; reliably at every new call.

2) LibreOffice remembers the window location in most positions. It just does not reopen it at the upper edge of the Unity desktop, but slides it half a centimeter to the bottom, as I reported before.
Comment 4 Jean-Baptiste Faure 2017-10-23 20:37:33 UTC
LO 5.4.2 is not the LO version provided by Ubuntu 16.04. Did you install the PPA version or the vanilla version provided by LibreOffice website ?

Did you play with the settings for window positioning in compiz configuration ?

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 5 Christian Lehmann 2017-10-24 06:32:08 UTC
I downloaded and installed the version offered on
https://de.libreoffice.org/download/libreoffice-fresh/
Please recall that the bug was already present in v.5.0, which was shipped with Ubuntu 16.04 and which I had before.

I can meanwhile add to my report that some applications have the same problem as LibreOffice, and others don't.

a) Stick to upper desktop margin:
Nautilus
Synaptic
FileZilla
LuckyBackup
Inkscape
Gimp

b) Slide down approximately by the vertical width of a menu bar:
LibreOffice
Bluefish

[c) Yet others, of course, never remember the last position of their window.]

Do you want a screen video for proof?

I surmise that the applications of #b have a communication problem with Unity.
Comment 6 Christian Lehmann 2017-10-31 11:24:54 UTC
While nobody seems to be willing to take up this bug, I can add an observation to comment #5:
After the last Ubuntu update, Nautilus is no longer in category #a, but in #b; i.e., it has the same positioning problem as LibreOffice.

And to take up Jean-Baptiste's question in comment #4: Yes, I did "play" with the settings in Compiz. And I confess that they are confusing, because not documented. As I already indicated, it is very possible that the differential behavior of the applications enumerated in comment #5 is due to the fact that some of them take Unity settings into account, and others don't.
Comment 7 Christian Lehmann 2017-11-07 11:02:37 UTC
I have now disabled the Ubuntu Unity Plugin (the only one that deals with distance of windows from the desktop edges) and can report that the LO bug persists.
Comment 8 Buovjaga 2017-11-13 18:27:51 UTC
Is it possible for you to test with Ubuntu 17.10, perhaps in a virtual machine?
Comment 9 Christian Lehmann 2017-11-14 20:51:30 UTC
Ubuntu 17.10 is shipped with LO 5.4.1.2. With this installation, things are worse. LO does not only forget the window position, but also its size. It always starts with a small window somewhere on the desktop.
Comment 10 Xisco Faulí 2018-11-27 12:59:07 UTC
Hello Christian Lehmann,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 11 Christian Lehmann 2018-12-19 20:51:10 UTC
In LO 6.1.4.2, it is exactly the same:
- I push the LO window to the top edge of the screen.
- I close LO.
- I call it again.
- It is half a centimeter below the top edge.
Comment 12 Xisco Faulí 2019-06-26 08:37:01 UTC
(In reply to Christian Lehmann from comment #11)
> In LO 6.1.4.2, it is exactly the same:
> - I push the LO window to the top edge of the screen.
> - I close LO.
> - I call it again.
> - It is half a centimeter below the top edge.

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 13 Christian Lehmann 2019-06-26 08:55:44 UTC
Here is the part of it that can be copied:

Version: 6.2.4.2
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 4; OS: Linux 4.18; UI render: GL; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

I can report that the problem persists in my current version.
Comment 14 Buovjaga 2019-06-26 09:06:20 UTC
(In reply to Christian Lehmann from comment #13)
> Here is the part of it that can be copied:
> 
> Version: 6.2.4.2
> Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
> CPU threads: 4; OS: Linux 4.18; UI render: GL; VCL: kde5; 
> Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
> Calc: threaded

What if you deactivate OpenGL in Tools - Options - LibreOffice - View - Use OpenGL for all rendering?
Comment 15 Christian Lehmann 2019-06-26 09:17:04 UTC
I cannot at the moment reproduce the bug. (It is frustrating: at one moment, the bug appears; 10 minutes later, with no changes made, it doesn't.) I will report again once I know more.
Comment 16 Dieter 2019-06-30 10:59:25 UTC
(In reply to Christian Lehmann from comment #15)
> I cannot at the moment reproduce the bug.

So perhaps we can close this for the moment as RESOLVED WORKSFORME and you can change it back to UNCONFIRMED, if it happens again and you can provide more details?
Comment 17 Xisco Faulí 2019-08-09 11:41:03 UTC
(In reply to Dieter Praas from comment #16)
> (In reply to Christian Lehmann from comment #15)
> > I cannot at the moment reproduce the bug.
> 
> So perhaps we can close this for the moment as RESOLVED WORKSFORME and you
> can change it back to UNCONFIRMED, if it happens again and you can provide
> more details?

yep, let's do it
Comment 18 Christian Lehmann 2019-10-31 15:31:22 UTC
Taking this up, I can now report the following:
LO Writer version 6.3.2.2 on Kubuntu 18.04 does remember the position and size of its last window. So the original complaint is resolved at least for this installation. I cannot tell how it would be under Ubuntu and with different desktop settings.

Moreover, other components of LO do not behave the same way. I will open a new report on LO Base.