Bug Hunting Session
Bug 113299 - Writer crashes by adding or update an alphabetical index
Summary: Writer crashes by adding or update an alphabetical index
Status: RESOLVED DUPLICATE of bug 113284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2017-10-20 16:32 UTC by geraldg
Modified: 2017-10-22 20:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with an Alphabetic Index at the end (813.31 KB, application/vnd.oasis.opendocument.text)
2017-10-20 16:45 UTC, geraldg
Details
Message by update (6.66 KB, image/png)
2017-10-20 17:10 UTC, geraldg
Details
bt with debug symbols (2.73 KB, text/plain)
2017-10-20 21:42 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description geraldg 2017-10-20 16:32:50 UTC
Description:
Writer crashes if I want to insert a new or update an existing alphabetical index.

Steps to Reproduce:
Open a new Writer document.
Write some text and insert some index entries.
Menu: Insert
Table of Contents and Index
Table of Contents, Index of Bibliography

choose: Alphabetical Index (or type an "a")
Writer crashes

Same problem by updating an Alphabetical Index by right-clicking in the Index and choosing update

Actual Results:  
Writer crashed.

Expected Results:
The Alphabetical Index will be created or will be updated


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 geraldg 2017-10-20 16:45:47 UTC
Created attachment 137162 [details]
Document with an Alphabetic Index at the end
Comment 2 geraldg 2017-10-20 17:00:54 UTC
mzalewski
18:57:52
Gerald: I could reproduce on Windows 10 32-bit
Comment 3 geraldg 2017-10-20 17:10:03 UTC
Created attachment 137163 [details]
Message by update
Comment 4 Julien Nabet 2017-10-20 21:42:59 UTC
Created attachment 137168 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
(gtk3 + enable-dbgutil)
Comment 5 Julien Nabet 2017-10-20 21:59:14 UTC
Tamas: I don't know how but reverting https://cgit.freedesktop.org/libreoffice/core/commit/?id=141d4427d2d2db6a16133fcf7571798233a99cb0 allows to not reproduce this one too.

(increase priority since:
- it's a crash
- it's a regression
)
Comment 6 Xisco Faulí 2017-10-22 20:26:41 UTC
Same commit as in bug 113284. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 113284 ***