Bug 113314 - Inserting bullet list content at some other indentation depth should apply the depth to the inserted text
Summary: Inserting bullet list content at some other indentation depth should apply th...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 115500
Blocks: Paste Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-10-21 01:43 UTC by Frank Brütting
Modified: 2019-03-27 11:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example (12.26 KB, application/vnd.oasis.opendocument.text)
2017-10-21 01:44 UTC, Frank Brütting
Details
Example 1 (815.60 KB, video/webm)
2018-03-24 17:27 UTC, Frank Brütting
Details
Example 2 (1.32 MB, video/webm)
2018-03-24 17:27 UTC, Frank Brütting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Brütting 2017-10-21 01:43:13 UTC
Description:
I copy some bullet list content of e.g. indentation depth 4. Then I create a new bullet point – but move it to the first indentation layer. When I then insert the clipboard content, the content gets indented to layer 4 instead of being matched to the first layer.

Additionally, if I want to insert the same passage not at the beginning of a new (empty) bullet point, but after some already existing text, the result is corrupted, because the indentation gets destroyed and seemingly tumultuous.

I attached an example document, where I marked, what I did, and at which position.

Steps to Reproduce:
1. Copy some bullet list content.
2. Create a new bullet point and move the cursor to another indentation layer.
3. Either fill in some text or leave this bullet point text blank.
4. Press <Ctrl + V>

Actual Results:  
A: Bullet point text remained blank before inserting:
⇒ Content is not inserted at the specified layer.

B: Bullet point text exists before inserting:
⇒ Content is not fully inserted at the specified layer, some content is inserted at the old layer.

Expected Results:
I expect that not the absolute layer is saved, but just the relative position. This way, the copied content would fit correctly into the place of the cursor.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Frank Brütting 2017-10-21 01:44:09 UTC
Created attachment 137176 [details]
Example
Comment 2 Dieter 2017-10-21 11:30:53 UTC
I took a look at your document. I'm not sure for 100%, but I think you have to use a list style in order to get the expected result. Can you try it?
Comment 3 Buovjaga 2017-11-07 15:59:17 UTC
(In reply to Dieter Praas from comment #2)
> I took a look at your document. I'm not sure for 100%, but I think you have
> to use a list style in order to get the expected result. Can you try it?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 Frank Brütting 2017-12-31 19:56:33 UTC
Have tried it with a list style, result is the same.

What’s the difference between (Shift +) F12 by the way? Isn’t this a somewhat hidden/unmodifyable list style? Why isn’t this directly connected to a list style?
Comment 5 Buovjaga 2018-01-07 15:05:07 UTC
Repro with the document.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: e1fb3d95ac6d58b60448981e82d90621cad7fea5
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 7th 2018

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Frank Brütting 2018-01-07 15:08:20 UTC
I also experienced that headers below a bullet get moved when I move the bullet up/down.

Could be ralated, as the environment isn’t correctly determined/differentiated…? Or should I open a new bug report for this?
Comment 7 Buovjaga 2018-01-07 15:17:05 UTC
(In reply to zyklon87 from comment #6)
> I also experienced that headers below a bullet get moved when I move the
> bullet up/down.
> 
> Could be ralated, as the environment isn’t correctly
> determined/differentiated…? Or should I open a new bug report for this?

If you can reproduce the problem from scratch with a fresh document, yes, open a new report.
Comment 8 Frank Brütting 2018-03-24 17:26:30 UTC
Could you please invest some time into this bug? Today I had to move around several parts of enumerations and that was a pretty horrible experience, because almost everytime I had to fix the indentation afterwards.

I use a list style for enumarations and after moving fore example one part around, which contains a heading and a following itemization, the heading got itemized too. Plus I had the problem, that "Ctrl + 0" didn’t work anymore, so the bullet wasn’t removed from the heading when I formatted it as "text body" (what normally works fine). That seems to me, that the whole structure gets corrupted. I attach two screencast, that show you what I mean.

Please implement unit tests! As this got worse with releases 5 and 6!
Comment 9 Frank Brütting 2018-03-24 17:27:06 UTC
Created attachment 140863 [details]
Example 1
Comment 10 Frank Brütting 2018-03-24 17:27:37 UTC
Created attachment 140864 [details]
Example 2
Comment 11 Buovjaga 2018-03-24 17:41:55 UTC
(In reply to zyklon87 from comment #8)
> Could you please invest some time into this bug?
...
> Please implement unit tests! As this got worse with releases 5 and 6!

Money, money, money! Give it and everything becomes possible.
Comment 12 Frank Brütting 2018-03-24 19:13:16 UTC
It’s easy asking for money. But as you might assume, as a private person I’m far from being able to pay developers – but at least I spend quite some time on debugging and programming free software and thus contribute quite a bit to the community. Please instead ask those bigger institutions which use LO in far bigger scale for investment.
Comment 13 QA Administrators 2019-03-25 03:44:37 UTC Comment hidden (obsolete)
Comment 14 Babak Razmjoo 2019-03-27 11:47:35 UTC
I can confirm that the bug is present in
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded