Bug 113324 - U+0020 SPACE is changed to U+00A0 NO-BREAK SPACE
Summary: U+0020 SPACE is changed to U+00A0 NO-BREAK SPACE
Status: RESOLVED DUPLICATE of bug 109343
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-21 14:24 UTC by Sam
Modified: 2017-10-25 10:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
an .odt file with text copied and pasted from the preview window of an external editor (9.84 KB, application/vnd.oasis.opendocument.text)
2017-10-21 14:26 UTC, Sam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sam 2017-10-21 14:24:21 UTC
Description:
LO Writer changes some instances of U+0020 SPACE to U+00A0 NO-BREAK SPACE if text from a text editor is copied and pasted into a Writer document.

It appears to me that these changes occur especially when a passage changes from roman to italic, or vice versa.

Steps to Reproduce:
1. Create an .md text file with both roman and italic passages, and normal spaces in between (e.g. in BBEdit, MultiMarkdownComposer).
2. From the preview pane in the text editor, copy and paste this text into a Writer document.
3. Some of the spaces of the original .md file have now been converted to no-break spaces.

Actual Results:  
see 3. above

Expected Results:
It should have kept the normal spaces as normal spaces.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Sam 2017-10-21 14:26:22 UTC
Created attachment 137186 [details]
an .odt file with text copied and pasted from the preview window of an external editor
Comment 2 Caolán McNamara 2017-10-21 15:34:44 UTC
I rather suspect writer is innocent, try ctrl+shift+v for the paste special dialog which lists all the formats the source application makes available to paste from. Is it *just* Unformatted text, or is there also e.g. HTML listed, and that selected as the default.

If there is both HTML and plain text available, see what happens if you try plain text vs html
Comment 3 Sam 2017-10-21 16:38:38 UTC
You are right: there are two pasting options (HTML and Unformatted text), and with Unformatted text the spaces render correctly in LO Writer.

But when Unformatted text is used, the formatting gets lost.
Comment 4 Alex Thurgood 2017-10-23 12:15:18 UTC
Sounds to me like a DUPLICATE of bug 109343 or at least pretty similar
Comment 5 Xisco Faulí 2017-10-25 10:58:55 UTC

*** This bug has been marked as a duplicate of bug 109343 ***