Bug 113350 - Opening the Print Preview for a large document is slower as it has been before
Summary: Opening the Print Preview for a large document is slower as it has been before
Status: RESOLVED DUPLICATE of bug 112989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-22 14:23 UTC by Telesto
Modified: 2017-11-06 20:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (29.25 KB, application/vnd.oasis.opendocument.text)
2017-11-06 20:05 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-22 14:23:58 UTC
Description:
Opening the Print Preview for a large document is slower as it has been before

Steps to Reproduce:
1. Open Writer & disable the spell checker
2. Open attachment 136841 [details]
3. Wait until the file is fully loaded (Process Monitor: CPU usage back to +/- 0%)
4. Click Print preview (18 seconds with LibO6 and 4-5 seconds with 5.1.0.0.alpha1+


Actual Results:  
18 seconds with LibO6 and 4-5 seconds with 5.1.0.0.alpha1+

Expected Results:
4-5 seconds


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: a4a182e24d2e3e954831a0a7c70a7299f28950cb
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-18_04:47:29
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.1.0.0.alpha1+
Build ID: 87ac0b1e75a880a68ecb748bd4b34ae5a3d2ae98
Locale: nl-NL (nl_NL)


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-10-26 23:04:56 UTC
> Version: 6.0.0.0.alpha0+
> Build ID: a4a182e24d2e3e954831a0a7c70a7299f28950cb
> CPU threads: 4; OS: Windows 6.3; UI render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-10-18_04:47:29
> Locale: nl-NL (nl_NL); Calc: CL

Out of curiosity, is it a daily build ? Could you please check with LibreOffice 6.0 alpha1+ ? I'm wordering if daily builds are slower than production releases...
Comment 2 Xisco Faulí 2017-10-26 23:06:03 UTC
OTOH, for this kind of tests, it would be good to try to many times, let's say, 10, and have an average number. Sometimes, it might be slower the first time...
Comment 3 Telesto 2017-10-29 16:51:50 UTC
(In reply to Xisco Faulí from comment #2)
> OTOH, for this kind of tests, it would be good to try to many times, let's
> say, 10, and have an average number. Sometimes, it might be slower the first
> time...

Repro with:
Versie: 5.3.7.2 
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL

No repro with
Versie: 5.3.7.2 
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: oud; 
Locale: nl-NL (nl_NL); Calc: CL


Tools -> Options -> Advanced: Expert Configuration search for "TextLayoutEngine" and edit to change "new|old" as needed. (Source: bug 89870 comment 32)
Comment 4 Telesto 2017-10-29 17:05:10 UTC

*** This bug has been marked as a duplicate of bug 112989 ***
Comment 5 Telesto 2017-11-06 20:05:53 UTC
Created attachment 137580 [details]
Example file

Only as addition
1. Open attached file
2. Scroll down/up with the page down/page up keys and monitor CPU usage