Bug 113397 - Global menu does not work with KDE Plasma 5.9 +
Summary: Global menu does not work with KDE Plasma 5.9 +
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Linux (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Environment
  Show dependency treegraph
 
Reported: 2017-10-24 12:08 UTC by Venca B Spam
Modified: 2018-12-13 00:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Proof that this works w/ the new kf5 frontend (1.09 MB, image/png)
2018-08-20 11:12 UTC, Katarina Behrens (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Venca B Spam 2017-10-24 12:08:01 UTC
Description:
Global application menu does not work with KDE Plasma 5.9 +

Observations:
- Please note that the KDE global menu works in Plasma since version 5.9 + (any attempts to test it in older version will not make sense - it is not there)
- Tested in KDE Neon Plasma 5.9 - 5.11.1

Although there may discussion about who should patch what, I believe this bug should be present here at least to draw the attention to this business requirement/issue and conserve discussion.

Steps to Reproduce:
1) Enable global menu in KDE Plasma.
2) Check that the global menu works in other applications.
3) Run any application from the LibreOffice package

Actual Results:  
The application menu is shown in the application window.


Expected Results:
The application menu should be shown in the top level panel (along the upper edge of the monitor).



Reproducible: Always

User Profile Reset: No

Additional Info:
I put this as major issue for me as the menu eats significant vertical space on my display.


User-Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 Xisco Faulí 2017-10-24 20:34:16 UTC
KDE5 support is under development in https://cgit.freedesktop.org/libreoffice/core/log/?h=feature/kde5

@bubli, is this bug reproduced on your side?
Comment 2 Xisco Faulí 2017-10-25 10:37:03 UTC
Venca,
I've just seen the KDE5 was merged today in master -> https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=dd7a3147f160813022d1c2724bbdf7fc46ffcc59..a555163e57e1a402ccd2a708304aabf212013706

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 3 Venca B Spam 2017-10-25 12:07:27 UTC
Is there build for x86_64 Linux (Ubuntu/Debian)?

I found only x86 deb packages, but they have Oct 19 timestamp (http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@71-TDF/current/master~2017-10-19_00.33.17_LibreOfficeDev_6.0.0.0.alpha0_Linux_x86_deb.tar.gz)

When I installed them LO crashed with:

```bash
user@redcat:~$ libreofficedev6.0 
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/opt/libreofficedev6.0/program/soffice.bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
```

For which I blame the wrong platform I used (package is x86 vs my system is x86_64).

Would you please point me to the right package and/or place where I can trigger Linux (Ubuntu/Debian) x86_64 build of the most recent master/current code.
Comment 4 Venca B Spam 2017-10-26 07:27:56 UTC
I am just curious if the build for Linux is failing or is just not scheduled to build daily builds for Linux?

I did try to find the build server itself, but did not succeed.

I would like to ask someone who knows to point me to the right place where I can find out how to get the daily build for Linux to test the recent KDE5 support.
Comment 5 Venca B Spam 2017-10-29 07:00:03 UTC
Finally yesterday's build is available which may include KDE Plasma 5.9+ support. (http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/2017-10-28_00.31.27/master~2017-10-28_00.31.27_LibreOfficeDev_6.0.0.0.alpha1_Linux_x86-64_deb.tar.gz)

Installation went smooth, start is also ok.

There is however still menu within the application.

Do I need to change LO preferences somehow to enable the global menu?
(found none by quickly browsing "Tools=>Options")
Comment 6 Venca B Spam 2018-02-08 11:53:45 UTC
Today I installed LO 6.x from the ppa:libreoffice/libreoffice-prereleases .

While running  KDE Plasma 5.12.x on Neon (based on Ubuntu 16.04), the global menu still does not work.

There is however new behavior observed. It looks like it first start with menu in  the application window and then it "hide" the menu. So it looks like it starts, then realize it should "activate" the global menu support, and then the menu disappears.
Comment 7 Maxim Monastirsky 2018-02-08 12:03:08 UTC
Global menu support isn't implemented yet for KDE, so I'm setting the bug to NEW and Severity to enhancement.

(In reply to Venca B Spam from comment #6)
> There is however new behavior observed. It looks like it first start with
> menu in  the application window and then it "hide" the menu. So it looks
> like it starts, then realize it should "activate" the global menu support,
> and then the menu disappears.
Right. Plasma "claims" that it supports a global menu, that's why we hide our in-window menu widget, but then it turns out the Plasma doesn't actually support the way we export menus... But this could happen only with gtk/gtk3 LO backends, so in the meantime I would suggest you to use the kde4 backend, which at least should have the in-window menu.
Comment 8 Venca B Spam 2018-02-08 12:10:51 UTC
Is there any roadmap for enhancements like this I can watch?
Comment 9 Heiko Tietze 2018-03-16 12:29:20 UTC
@Xisco: I think we should raise the importance (and set it as bug) because the global app menu is a primary feature for KDE users and the issue is reported several times.

https://bugs.kde.org/show_bug.cgi?id=391868 (more info in the referenced forum post)
Comment 10 Xisco Faulí 2018-03-19 12:17:04 UTC
Should we wait for Plasma 5.13 -> http://blog.broulik.de/2018/03/gtk-global-menu/ ?
Comment 11 Heiko Tietze 2018-03-19 12:19:58 UTC
(In reply to Xisco Faulí from comment #10)
> Should we wait for Plasma 5.13 ->

Sure, and get Kai's opinion too.
Comment 12 Miloš Jovanović 2018-08-18 10:23:51 UTC
This also produces a potentially more severe compatibility bug. If I am using a Global Menu Applet, the menu in Libreoffice simply does not show at all. This is regardless of the environment variable. 

When SAL_USE_VCL_PLUGIN is set to kde4 (as Maxim suggests above) the in-application menu simply does not show. The app does use KDE open/save dialogs. The temporary fix is to remove the Global Menu Applet completely.

Using Plasma 5.13.2 on Debian Buster.
Comment 13 Katarina Behrens (CIB) 2018-08-20 11:12:05 UTC
Created attachment 144328 [details]
Proof that this works w/ the new kf5 frontend

The top-level LibO menu appears in global menu w/ the new kf5 frontend ( scheduled for LibO 6.2 if distro packagers enable it). I'm not lying, see attached screenshot.

As for other frontends: this can't be fixed in kde4, like not at all

IDK what's the exact status of gtk3 and gtk3_kde5 but https://www.reddit.com/r/linux/comments/837b4/plasma_513_will_have_global_menu_support_for_gtk/ suggests that one might need Plasma 5.13 or newer to see a menu of gtk app in the global menu

Anyway I can't fix gtk, it's outta the scope of my knowledge, sorry
Comment 14 Heiko Tietze 2018-08-20 11:22:49 UTC
(In reply to Katarina Behrens (CIB) from comment #13)
> Created attachment 144328 [details]
> Proof that this works w/ the new kf5 frontend

Looks good, so why not close this ticket?
Comment 15 Katarina Behrens (CIB) 2018-08-20 11:29:57 UTC
> Looks good, so why not close this ticket?

b/c it might still be broken for non-kf5 frontends? Can some1 confirm it?
Comment 16 Buovjaga 2018-08-28 16:32:47 UTC
Tried with gtk3_kde5 LibO 6.1.0 on Manjaro and the Global menu worked.
Comment 17 Andras 2018-12-10 19:20:11 UTC
System:
----------
KDE neon 5.14
KDE Plasma version: 5.14.4
KDE Frameworks Version: 5.52.0
Qt Version: 5.11.2
Kernel Version: 4.15.0-42-generic
OS Type: 64-bit
Flatpak version: 1.0.1
---------------------------------------------------------------

Installed Libreoffice versions:
--------------------------------
dpkg:
-----
Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.18.04.1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
---------------------------------------------------------------
Flatpak/Flathub:
----------------
Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Flatpak
Locale: en-US (en_US.UTF-8); Calc: group threaded
---------------------------------------------------------------
Appimage:
----------
Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: CL
---------------------------------------------------------------


I don't really know what's going on between LibreOffice and KDE Plasma's global menu in deep however I'm just confused about the lot of info from different sources and situations. For example:
Even KDE global menu itself is problematic;
For global menu, you have to set vcl to use GTK but you'll got GTK downloads and printing dialogues instead of KDE then;
Flatpak LibreOffice uses GTK vcl while dpkg and appimage ones uses KDE vcl.
etc
The main thing that I'm not able to use LibreOffice through dpkg installataion on KDE neon if I'd like to keep AppArmor in use so I decided to go with Flatpak Flathub version of LibreOffice because that's the most convenient after dpkg version regarding to upgrades.
Anyways, global menu issue is still persists on my system with all version of LibreOffice above. As I mentioned the older dpkg and the newer appimage version uses KDE vcl and they won't work with KDE global menu at all. The interesting part comes with Flatpak's LibreOffice what uses the GTK theme. Although global menu works with its vcl adjusted to GTK however it just keeps its own menubar too. I know there is an option to hide menubar but that's just not the solution here although I'd be glad if LibreOffice would keep the menubar close. It keeps reopening the menubar once LibreOffice closed. Let me know if there is any solution to this while this issue still not solved entirely or let me now if I reported it in the wrong place or if I should report this somewhere else too. Thanks!
Comment 18 Xisco Faulí 2018-12-12 16:42:40 UTC
@Andras, you're testing with LibreOffice 6.1.3.2
This issue should be fixed in LibreOffice 6.2. You can download the beta1 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases
Comment 19 Andras 2018-12-13 00:28:53 UTC
(In reply to Xisco Faulí from comment #18)
I can confirm, downloaded 'pre release full' Appimage works great too, thank you so much guys for all the work and for this awesome software!