Bug 113422 - Crash in: ScPreview::MouseMove(MouseEvent const &)
Summary: Crash in: ScPreview::MouseMove(MouseEvent const &)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL: https://crashreport.libreoffice.org/s...
Whiteboard: target:6.0.0
Keywords: bibisected, bisected, regression
: 113632 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-24 22:42 UTC by max7
Modified: 2017-11-03 17:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["ScPreview::MouseMove(MouseEvent const &)"]


Attachments
Information about the place exception from "Windbg" (3.24 KB, text/plain)
2017-10-25 00:13 UTC, max7
Details

Note You need to log in before you can comment on or make changes to this bug.
Description max7 2017-10-24 22:42:18 UTC
This bug was filed from the crash reporting server and is br-a7b25a91-bca4-46a1-8a13-8dfbd142ef9d.
=========================================
:-)
Comment 1 Xisco Faulí 2017-10-24 23:09:18 UTC Comment hidden (obsolete)
Comment 2 max7 2017-10-25 00:13:39 UTC
Created attachment 137267 [details]
Information about the place exception from "Windbg"

The error is stably reproduced in "Calc" in the "Print Preview" mode when the cursor moves over the viewing area.
Comment 3 Xisco Faulí 2017-10-25 00:40:39 UTC
Regression introduced by:

author	Noel Grandin <noelgrandin@gmail.com>	2017-10-18 18:50:02 (GMT)
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2017-10-19 07:05:29 (GMT)
commit	0ad8447d3199e1c1d1f7d6ddabc9b4cded99c2d6 (patch)
tree	a428f0e9bc8c0cb9f6f0ad8673b16481193fe364
parent	856df6d40690500453092419b2c71e91e2c5de25 (diff)
dyncolcontainer: convert nRight to std::vector

Bisected with: bibisect-linux64-6.0

Adding Cc: to Noel Grandin
Comment 4 max7 2017-10-25 03:10:31 UTC
 
Possible growth place of an exception:  https://cgit.freedesktop.org/libreoffice/core/tree/sc/source/ui/view/preview.cxx?id=0ad8447d3199e1c1d1f7d6ddabc9b4cded99c2d6#n1359 
 
========================================= 
 
Perhaps "mvRight" was not initialized before calling "ScPreview :: MouseMove", as here:  https://cgit.freedesktop.org/libreoffice/core/tree/sc/source/ui/view/preview.cxx?id=0ad8447d3199e1c1d1f7d6ddabc9b4cded99c2d6#n434
Comment 5 Julien Nabet 2017-10-25 07:01:53 UTC
Noel: couldn't nRight/mvRight have a fixed size to MAXCOL+1 and so what about using http://en.cppreference.com/w/cpp/container/array ?
Comment 7 Noel Grandin 2017-10-25 13:48:46 UTC
the intent of the commit was to avoid allocating more columns than we actually need, since we intend to raise the column limit
Comment 8 Julien Nabet 2017-10-25 21:32:01 UTC
Noel: ok then, I understand better.
(sorry, I had forgotten to put myself in cc)
Comment 9 Commit Notification 2017-10-27 07:54:45 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f3ca2e63b8145b504f764a17ab61d8a93f15a60

tdf#113422 Crash in: ScPreview::MouseMove(MouseEvent const &)

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 max7 2017-10-30 03:33:33 UTC
Version: 6.0.0.0.alpha1+ (x64)
Build ID: d30522e46ca884e9bc74af21711d9537e8118859
CPU threads: 8; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-10-30_00:25:37
https://hub.libreoffice.org/git-core/d30522e46ca884e9bc74af21711d9537e8118859

In this version there is no such bug :-)
Comment 11 Xisco Faulí 2017-11-03 17:02:39 UTC
*** Bug 113632 has been marked as a duplicate of this bug. ***