Bug 113450 - Cannot enter text involving the ALT Gr key in the find and replace dialog box (OpenGL disabled)
Summary: Cannot enter text involving the ALT Gr key in the find and replace dialog box...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Find&Replace-Dialog
  Show dependency treegraph
Reported: 2017-10-25 17:17 UTC by Christian Lehmann
Modified: 2019-04-26 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2017-10-25 17:17:10 UTC
Both in the "Search" line and in the "Replace" line, pressing the ALT key highlights the text already contained in the line (for overwriting). As a consequence, it is impossible to type an expression containing a character (in non-first position) involving the ALT key.

Steps to Reproduce:
2. Type A[ in the search line or in the replace line.

Actual Results:  

Expected Results:

Pressing the ALT key should not highlight the content of the dialog box lines.

Reproducible: Always

User Profile Reset: No

Additional Info:
While one keeps the ALT key pressed, one can go on typing ALT characters. Once one releases it and presses it again, one cannot add anything, for the above-mentioned reason.

I seem to remember that this is an old bug; I think I have seen it in v. 5.0.

User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Christian Lehmann 2017-10-27 12:37:59 UTC
Sorry for my mistake: The correct description of the bug refers to the ALT-Gr key, not the ALT key.

Again, the example I gave ('[') presupposes a German keyboard layout. To reproduce the bug with an English keyboard, substitute '[' in my example 'A[' by any character involving the ALT-Gr key.
Comment 2 Dieter 2017-10-28 07:45:25 UTC
Not reproducible for me.

Version: (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group


Version: (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

What version of LO do you use? Can you try it with an actual version of LO 5.4 or I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Christian Lehmann 2017-10-29 16:19:37 UTC
As you may have seen from my bug description, I did use LO v. on Ubuntu 16.04. There the bug is reliably reproducible all the time. Sorry I do not pretend to be an alpha tester.

However, I can confirm that the bug is absent from the Windows version of LO.
Comment 4 Buovjaga 2017-11-09 15:36:13 UTC
Works for me. I also tried GTK3 plugin. Finnish keyb layout.

What if you test other layouts?

Change back to UNCONFIRMED after you have provided the information.

Arch Linux 64-bit, KDE Plasma 5
Build ID: 5.4.2-2
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 5 Christian Lehmann 2017-11-14 18:07:52 UTC
I've just tested LO on Kubuntu 14.04. The bug does not appear.
Comment 6 Buovjaga 2017-11-14 18:34:59 UTC
I meant testing other keyboard layouts with your Ubuntu 16.04, LibO 5.4.
Comment 7 Christian Lehmann 2017-11-14 19:39:57 UTC
I just tried it on LO as shipped with Ubuntu 17.10.
The bug does not occur.
It appears that we are faced with a failure of cooperation between LO and the Unity desktop.
Comment 8 Christian Lehmann 2017-11-15 07:43:59 UTC
I switched the keyboard layout to English, so that [] do not require the ALT-Gr key, but this key is still available for other characters. Same result: pressing the ALT-Gr key marks the entire text already contained in the Search field of the dialogue box.
Comment 9 Xisco Faulí 2018-11-27 12:59:26 UTC
Hello Christian Lehmann,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 10 Christian Lehmann 2018-12-19 20:53:53 UTC
Resolved in
Comment 11 Xisco Faulí 2018-12-19 22:33:34 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 12 Christian Lehmann 2018-12-20 07:47:05 UTC
I am awfully sorry. I yesterday tested the behavior of the 'Find&Replace' dialogue at a moment where OpenGL was enabled. At that moment, the reported problem did not exist, so I thought it was solved. However, OpenGL does not work in my installation, so I had to disable it again. And now the problem of the Alt and AltGr keys reappears:
1) In Wirter, press either CTRL-h or CTRL-f.
2) Type anything.
3) Press either Alt or Alt-Gr key.
4) The text entered before is highlighted, so it will disappear once you hit the next key.
Comment 13 Dieter 2018-12-20 08:45:28 UTC
I can't confirm it with

Version: (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

OpenGL is diabled
Comment 14 Christian Lehmann 2018-12-20 08:53:21 UTC
The same happens to me in some HTML forms which require me to fill in the field 'email address'. At the point where I press Alt-Gr to type '@', the entire text entered up to then is highlighted and disappears upon completing '@'.
It could be a problem of the OS (I have Ubuntu) or of some routine used by both Linux LibreOffice and those HTML forms.
Comment 15 mattia.b89 2019-04-13 19:55:28 UTC
I can not reproduce the bug in

Build ID: 6.2.2-4
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: it-IT (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 16 Christian Lehmann 2019-04-26 09:32:10 UTC
The bug is not present in
Kubuntu 18.04
KDE Plasma Version 5.44.0
As I remarked earlier, it may have been a problem of (interaction with) the Unity desktop.
If and when I stumble again over the bug, I will report.
Comment 17 Buovjaga 2019-04-26 10:25:50 UTC
Ok, let's close for now.