Bug 113467 - Random hangs -- multiple situations
Summary: Random hangs -- multiple situations
Status: RESOLVED DUPLICATE of bug 103571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2017-10-26 19:55 UTC by Jon R Kibler
Modified: 2017-11-10 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon R Kibler 2017-10-26 19:55:09 UTC
Writer has been hanging anywhere from a few seconds to over a minute under a lot of seemingly unrelated circumstances, such as:

1) Creating a new writer document
   a) New document simply takes "forever" to open, and/or
   b) Once new document is open, you cannot click in the document to start typing, etc.

2) Opening an existing document (usually opens immediately, but hangs before allowing you to even select the document)

3) Click in the document to start a selection point, then shift-click to mark the end of the selection (usually selects text immediately, but someones can take as long as 30 or more seconds to select as short as a single sentence)

4) Changing fonts via toolbar
   a) Sometimes it takes "forever" for the dropdown to appear
   b) Sometimes it will not react when selecting a font (dropdown just freezes, then returns to original selection in tool bar)
   c) Most of the time it works okay, but doesn't just enough to be annoying

5) When typing (this is the really annoying one, as I touch-type, and it isn't until the keyboard buffer fills and I start getting audio alerts I realize the LO has frozen -- the buffered typing eventually shows up, but it is hurry-up-and-wait)

6) When switching between already open documents, either via Windows menu or CMD+` shortcut.
   a) When using menu, it simply freezes on selection and nothing happens until LO unfreezes and switches to selected document
   b) When using shortcut, LO simply freezes


I have checked Activity Monitor when these freezes occur, and LO is using essentially no resources, then has a big spike when it unfreezes. No other processes are running that would eat up CPU or memory, either. I always have plenty of free memory.
Comment 1 Xisco Faulí 2017-10-26 22:58:18 UTC Comment hidden (obsolete)
Comment 2 Jon R Kibler 2017-10-27 09:47:41 UTC
I have reset my user profile and will report back whether or not that fixed the problem.

Also, note that this could be related to bug 113468 which I have also been experiencing.
Comment 3 Jon R Kibler 2017-10-29 14:32:37 UTC
Resetting my profile did not fix the problem.

In fact, I am even having it occur in Safe Mode.

I just created a new Writer document (CMD-N) and it was between 10 and 15 seconds before I could start typing in the new window. At the time I opened it, I had three other small writer documents open (2 to 4 pages each).
Comment 4 Jon R Kibler 2017-10-29 15:14:26 UTC
Reading through bugs related to my  bug 113468 has left me with a thought: Sierra -- at least from the user's perspective -- changed the way the O/S handles spellchecking.

I do have spelling and grammar checking turned on. I'm wondering if that could be at least part of this problem -- especially the freezes when typing: Is spelling checking trying to occur and there is simply a delay in looking up some word?

I am going to turn both off and will report back in a couple days.
Comment 5 Jon R Kibler 2017-11-04 20:10:42 UTC
For about a week now, I have been running with spelling and grammar checking as I type turned off. I have also reset my profile and tried running in safe mode. I have also ejected all network and externally attached drives, and I have set my Mac's internal drive to not sleep.

I can say from this testing that turning off spelling and grammar checking seems to improve the performance, but that could also just be a coincidence, as I am still having serious problems with hangs.

For example, I just created a new writer document. After using the menu to specify I wanted a new text document, it opened within a couple seconds, and as soon as I clicked in the document, I was able to type. However, after typing my header line and adding a couple blank lines below it, when I selected the header line and went to the toolbar to change the font size, as soon as I pulled down the font size menu, LO froze. It took about 30 seconds for it to again respond, and the response was to close the drop down menu. When I went to type the font size in the tool-bar box, it allowed me to type it, but as soon as I selected away from the tool-bar, it again froze, but this time for about 10 seconds.

I'm open to additional testing suggestions.

Thanks!
Comment 6 Jon R Kibler 2017-11-04 20:14:21 UTC
I should also add that this Mac has a large number of fonts (~850) installed. However, until recently, this has not been an issue, and all of these fonts have been installed since a previous Mac, at least 10 years go.

So, unless something in LO or macOS has changed regarding font handling, I don't think this is the issue, but thought I would mention it just for completeness.
Comment 7 Telesto 2017-11-05 10:51:14 UTC
Sounds a bit like bug 103571. OSX is broadcasting "screenParametersChanged" quite often (since Yosemite). When minimising the screen or when awake after sleep. LibreOffice reacts on it as if the physical display and/or monitor size has changed. Loading all fonts again. 

LibO 4.3.7.2 should 'resolve' the issue for now:  
https://downloadarchive.documentfoundation.org/libreoffice/old/4.3.7.2/mac/
Comment 8 Jon R Kibler 2017-11-05 15:02:50 UTC
(In reply to Telesto from comment #7)
> Sounds a bit like bug 103571. OSX is broadcasting "screenParametersChanged"
> quite often (since Yosemite). When minimising the screen or when awake after
> sleep. LibreOffice reacts on it as if the physical display and/or monitor
> size has changed. Loading all fonts again. 
> 
> LibO 4.3.7.2 should 'resolve' the issue for now:  
> https://downloadarchive.documentfoundation.org/libreoffice/old/4.3.7.2/mac/

If it was fixed, it is now back. Confirming that LO freezes when switching to an open document after sleep -- not 100% of time, but at least 75%.
Comment 9 Alex Thurgood 2017-11-10 08:00:08 UTC
@Jon : we need to focus on one buggy behaviour for this report. The others should be put into separate reports. To me, at least some of what you report is already reported in earlier bug reports.


Telesto's comment to you with regard to waking after sleep or window reduction was a suggestion to install a much older version of LibreOffice that did not show this problem, i.e. the problem in question started occurring with versions later than version 4372 and has not yet been fixed.
Comment 10 Alex Thurgood 2017-11-10 08:04:57 UTC
@Jon : we need to focus on one buggy behaviour for this report. The others should be put into separate reports. To me, at least some of what you report is already reported in earlier bug reports.


Telesto's comment to you with regard to waking after sleep or window reduction was a suggestion to install a much older version of LibreOffice that did not show this problem in such an extreme form, i.e. the problem in question started being more noticeable with versions later than version 4372 and has not yet been fixed, even though he found what is believed to be the root cause, i.e. complete font reload from the terminal session that launches LO when the application screen is refreshed (e.g. from reduced state or sleep).
Comment 11 Alex Thurgood 2017-11-10 08:06:50 UTC
I'm going to mark this as a duplicate of bug 103571.

*** This bug has been marked as a duplicate of bug 103571 ***