Download it now!
Bug 113470 - DRAW: add functional for convert any figure to any figure
Summary: DRAW: add functional for convert any figure to any figure
Status: RESOLVED DUPLICATE of bug 89087
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DTP Draw-UX
  Show dependency treegraph
 
Reported: 2017-10-26 21:07 UTC by Roman Kuznetsov
Modified: 2017-11-09 16:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-10-26 21:07:33 UTC
Description:
add to Draw functional for convert any figure to any figure. For example, circle to rectangle, or star to triangle. All properties of figure must be saved: fill color, border color, text, arrange, etc. If we want to convert many figures in one time, then all properties for new figures must be set to default, but text must be saved as it was.
It functional would be need for fast editing flowcharts

Steps to Reproduce:
1. It is Enhancement
2.
3.

Actual Results:  
there is not functional for convert any figure to any figure 

Expected Results:
there is functional for convert any figure to any figure 


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Buovjaga 2017-11-09 11:58:35 UTC
My first thought was "sounds like a job for a macro or an extension", but smooth switching of element types in a flowchart might be cool to have in-built.

Let's see what the UX team thinks of this - in or out?
Comment 2 V Stuart Foote 2017-11-09 13:25:57 UTC
This would be useful, and is in line with making Draw a better tool for graphics work.

Believe since shape is a attribute of the draw object, it should be possible to change it once instantiated--but the details of the conversion would be a challenge. 

Converting the shape, two facets that would have to be held constant would be the center point and the scale/extents of the object--to hold relative position on canvas. 

Other attributes could be retained, or toggled to follow current tool settings (e.g. area fill, border colors, text color & font, etc.).
Comment 3 Heiko Tietze 2017-11-09 15:01:07 UTC
Although the other ticket asks for a context menu the requested function is the same: turn a rectangle into a circle and keep all properties.

*** This bug has been marked as a duplicate of bug 89087 ***
Comment 4 Heiko Tietze 2017-11-09 15:01:25 UTC Comment hidden (obsolete)
Comment 5 Regina Henschel 2017-11-09 15:55:16 UTC
"Any" to "Any" is nonsense, you surely don't want to make a textbox to a measure line. But some conversions might be useful and possible:

A
There a some custom-shapes, which exist as primitive drawing too, e.g a rectangle. These shapes look equal but they have different characteristics in regard to their text. So a conversion for and back would be useful for the user to get different text features.

B
Most of the current custom-shapes are not of generic "non-primitive" type, but they have a specific type e.g. "left-right-arrow". For them the entire geometry (element <draw:enhanced-geometry>) is predefined and has nothing user-specific. So it would be possible to exchange one geometry with another. From a user point of view that would be a nice feature, e.g. exchange a five-point-star with six-point-star. Thereby the size and position and the text is independent from the geometry and can be kept. 

C
Custom shapes are based on curves. So a Bézier-curve could be converted to a custom-shape with putting the path definition from the Bézier-curve into the geometry of the custom-shape. It would be a very simple shape, without any handles. Similar to A, the shapes would look the same, but the text properties are different. Perhaps a first step, to get a UI to create own custom-shapes?

D
Convert a custom-shape to a Bézier-curve, so that the text in the custom-shape is retains and is still editable as text. The current conversion turns the text to a curve. A lot of custom-shapes have a simple geometry, that can be expressed by a single Bézier-curve.
Comment 6 V Stuart Foote 2017-11-09 16:03:04 UTC
@Regina, did you mean to mark this fixed?
Comment 7 Regina Henschel 2017-11-09 16:27:41 UTC
I have shown several aspects of converting, so having that in one issue is not possible anyway. I only want to show, that "Any" to "Any" is not specific enough to be handled. This was thought as remark, in case such topic is considered as suitable for GSoC.

Setting this as duplicate of bug 89087 is OK; that bug fits to aspect B. Aspects A and D are similar to bug 64612. Aspects can be extracted as issue if needed.

"Fixed" duplicate is OK for me.
Comment 8 Buovjaga 2017-11-09 16:31:46 UTC

*** This bug has been marked as a duplicate of bug 89087 ***