Bug 113475 - Libreoffice main icon appears dock/launcher instead of module app icons in Ubuntu 17.10
Summary: Libreoffice main icon appears dock/launcher instead of module app icons in Ub...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2017-10-27 08:28 UTC by Tom Moorhouse
Modified: 2018-12-03 12:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How the screen looks before I open writer (1.82 MB, image/png)
2017-11-10 12:43 UTC, Tom Moorhouse
Details
When I click on writer, I get a new icon, with the writer window attached (176.33 KB, image/png)
2017-11-10 12:43 UTC, Tom Moorhouse
Details
And if I additionally open Calc then this too attaches to the white icon (1.66 MB, image/png)
2017-11-10 12:44 UTC, Tom Moorhouse
Details
Screencast (1.40 MB, video/webm)
2017-11-10 18:32 UTC, Tom Moorhouse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Moorhouse 2017-10-27 08:28:26 UTC
Description:
- Applies to Libreoffice 5.4.2.2 in Ubuntu 17.10
- Correct icons for writer, calc etc able to be docked with Ubuntu dock
- Clicking on any spawns a new, white, generic icon in the dock.
 - Only the generic white icon is operational for window switching (i.e. one calc and one writer window will create two red dots beneath the white icon, and both can be accessed from this, not from their respective correct icons).
- White, generic, icon also appears in Ubunutu's program list as "Libreoffice" alongside the correct icons for writer, calc etc.

Steps to Reproduce:
1. Install Libreoffice on fresh installation of ubuntu 17.10
2. Place calc / writer icons in dock / favourites bar
3. Click on either

Actual Results:  
A new white generic icon appears in the dock/favourite bar that acts as the switcher between Libreoffice windows. Clicking again on the correct calc or writer icons merely opens more windows (more red dots beneath the generic icon).

Expected Results:
I expected no white icon to appear and the respective windows to be proportionally accessible from the correct writer / calc icon (i.e. if I had two writer windows and one calc window open, I would expect two red dots beneath the writer icon and one beneath the calc icon - and clicking the calc icon should bring up the single calc window, not all three libreoffice windows simultaneously, as happens with the white icon). 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This is annoying but not crippling.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Yousuf Philips (jay) (retired) 2017-11-10 12:25:22 UTC
Hi Tom,

Is the 5.4.2 obtained the libreoffice PPA or from the libreoffice.org website?

Please copy and paste version information found in the Help > About LibreOffice dialog.

Is it possible for you to do a screencast of the issue? You can use gtk3's built in screen recorder by pressing shift+ctrl+alt+R.
Comment 2 Tom Moorhouse 2017-11-10 12:43:13 UTC
Created attachment 137660 [details]
How the screen looks before I open writer
Comment 3 Tom Moorhouse 2017-11-10 12:43:57 UTC
Created attachment 137661 [details]
When I click on writer, I get a new icon, with the writer window attached
Comment 4 Tom Moorhouse 2017-11-10 12:44:58 UTC
Created attachment 137662 [details]
And if I additionally open Calc then this too attaches to the white icon
Comment 5 Tom Moorhouse 2017-11-10 12:47:37 UTC
Hi there!

I installed from the PPA, and the info from the About Libreoffice is as follows:

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.17.10.1~lo1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group


The screencast didn't work too well (crashed my laptop) so I've included screenshots. Hope that's okay! Let me know if you need more information...

Cheers,
 Tom
Comment 6 Tom Moorhouse 2017-11-10 18:32:05 UTC
Created attachment 137674 [details]
Screencast

Finally managed to record a proper screencast of the problem. Hope it helps!
Tom
Comment 7 Yousuf Philips (jay) (retired) 2017-11-10 21:36:06 UTC
So I can confirm that there isnt a problem with version 5.4.1.2 of LibreOffice that comes bundled with Ubuntu 17.10, but when upgrading to 5.4.2 from the PPA, the issue does arise.

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.17.10.1~lo1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

I tested and the /usr/share/applications/libreoffice-writer.desktop file didnt change after upgrading, so not sure what the problem could be caused by but dont believe it is our bug and likely a bug with ubuntu or the dock.

Buovjaga, Xisco: whats your take?
Comment 8 Yousuf Philips (jay) (retired) 2017-11-10 22:00:04 UTC
So i installed 5.4.3 from the libreoffice website and it worked correctly, so this issue is a ubuntu build bug an not our bugs, so please file the bug with them.

https://bugs.launchpad.net/~libreoffice
Comment 9 Dan Dascalescu 2018-12-03 02:42:26 UTC
I have the same problem with v6.2 dev on Ubuntu 16, installed alongside 5.4 stable.

I've installed the 6.2 .deb packages from https://www.libreoffice.org/download/download/?type=deb-x86_64&version=6.2.0&lang=en-US by running `sudo dpkg -i *.deb`.

The icons show correctly the dash, but in the taskbar I see the generic question mark icon.

LibreOffice 5.4 icons show correctly in both locations.

LibreOffice 6.2 .desktop files appear to be correctly installed in /opt/libreofficedev6.2/share/xdg and symlinked from /usr/share/applications.

What can I do? Should we officially document this situation somewhere, since I'm not alone? I found random answers online for other versions of LO, but official guidance would be great:

* https://ubuntuforums.org/showthread.php?t=1795260
* https://askubuntu.com/questions/763335/how-do-i-get-the-right-libreoffice-calc-icon-into-the-launcher
Comment 10 Heiko Tietze 2018-12-03 09:09:38 UTC
(In reply to Dan Dascalescu from comment #9)
> What can I do? Should we officially document this situation somewhere, since
> I'm not alone? I found random answers online for other versions of LO, but
> official guidance would be great:

Well, reopened tickets don't get much attention and writing a new one is pretty simple. So this would be my choice.
All your reference are completely outdated as we are continuously working on all pieces. Of course, the issue might have been reintroduced.