Download it now!
Bug 113487 - LibreOffice file chooser dialog does not remember last used size
Summary: LibreOffice file chooser dialog does not remember last used size
Status: CLOSED DUPLICATE of bug 74439
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-10-27 20:36 UTC by David C. Rankin
Modified: 2020-05-17 14:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David C. Rankin 2017-10-27 20:36:42 UTC
Version: 5.3.5.2
Build ID: 30m0(Build:2)
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: x11; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Leap 42.2 x86_64

Previously File with OpenSuSE, they requested it move upstream:
https://bugzilla.suse.com/show_bug.cgi?id=1065398

This isn't a showstopper, but it is annoying as all get-out.

The file chooser dialog for libreoffice does not remember its last used size. Every time you open a file, you have to resize the dialog to be able to see your directory names and you have to resize the total width to be able to see your file information.

I have used LO for years and it always remembered the last used size of the file dialogs. Now after the switch to gtk+3, that does not work. I end up having to resize that thing every time I use writer or calc.

Before, that information was properly saved in ~/.config/gtk-2.0/gtkfilechooser.ini. There is no similar file in ~/.config/gtk-3.0 and nothing related to the file chooser. Is there another file that should capture the chooser width and height?
Comment 1 Mike Kaganski 2017-10-27 21:31:05 UTC
Well, AFAICS the dialog on your screenshots is not a system file open dialog, but LibreOffice own dialog (activated in Options-LibreOffice-General). And I can reproduce the behavior with LibreOffice file dialog size being reset using:

Version: 5.4.2.2 (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: ru-RU (ru_RU); Calc: CL

(but the position is saved, so that standard-sized dialog appears with top left corner at the place where that corner of resized dialog was). And also I see the same behaviour with:

Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Locale: ru_RU

but not with:

Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

(so it's a regression, but not new; and also has nothing to do with gtk, because reproducible on Windows). Possibly you had used OS/WM dialogs previously, and so didn't experience the problem.
Comment 2 Mike Kaganski 2017-10-28 07:05:20 UTC
~/bibisect-44max$ git bisect log
# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'master' 'oldest'
# bad: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect bad 8cf60cc706948588e2f33a6d98b7c55d454e362a
# bad: [d9885f526fc7a09cc8f9f8ee643af1b966be24bb] source-hash-d1465c64c6f64ad8dd25e40cdc69649b24b305ea
git bisect bad d9885f526fc7a09cc8f9f8ee643af1b966be24bb
# good: [e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a] source-hash-dc9cc46f3223aff3f85d3ce9696178a5f4d3d087
git bisect good e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a
# good: [1477f347fb61b5b07de64312247b49371812f5b4] source-hash-4598bbe41d0906a34ceb1126c7fce2108642cd8e
git bisect good 1477f347fb61b5b07de64312247b49371812f5b4
# good: [fdbfc593506d9f38152b80f14c9e7afdbef0b40a] source-hash-6024ddbfac8e62db50dd5352d610c87d279627de
git bisect good fdbfc593506d9f38152b80f14c9e7afdbef0b40a
# good: [b1d1e3e3ac1515cf33be95eba837476142fb6ca8] source-hash-f55ddffd7e81cc8f3314047a6aa62991e2d293b1
git bisect good b1d1e3e3ac1515cf33be95eba837476142fb6ca8
# bad: [163b7bd042acbad89907ad1e16c268229c8468a0] source-hash-e123226d874d59799ba4ca2a8919e50e7eb2ba3b
git bisect bad 163b7bd042acbad89907ad1e16c268229c8468a0
# good: [4b717bca8a28effd41dea7fa15191d6ad271ee5e] source-hash-c99f264be5eaf481f88606e2606c34170675c1b4
git bisect good 4b717bca8a28effd41dea7fa15191d6ad271ee5e
# good: [fefecd6b9475adfe2b04c5aefc575c93ec73460f] source-hash-0223eb2c6498a40a8d32575c9af189c570e490f6
git bisect good fefecd6b9475adfe2b04c5aefc575c93ec73460f
# bad: [fb832ac62618d270f2a2d18bdd29743273033132] source-hash-d48af86c9b745d750c97ba9b1c59ea936bcab0ae
git bisect bad fb832ac62618d270f2a2d18bdd29743273033132
# good: [2b816c44ec70b743ef29d091031d1f51c73bb9ad] source-hash-4771c8836a3e4d5e8ac25a7212293a13fb1e73ba
git bisect good 2b816c44ec70b743ef29d091031d1f51c73bb9ad
# good: [881fde319456c7fa4f90392a1f41f8c77877485c] source-hash-8a0df1b7e50ee4e39be0242ca245627b4eedd7e5
git bisect good 881fde319456c7fa4f90392a1f41f8c77877485c
# bad: [5895f4f01b8896121609b0caa70f362b90772640] source-hash-f90eb33a268bdcd1c52aea5670a58267b0907096
git bisect bad 5895f4f01b8896121609b0caa70f362b90772640
# good: [38a2aeec1468993ba52badac602c3fe338fe8a82] source-hash-b00a59287e0b1dcc0a46dd18e5e884282eb859f3
git bisect good 38a2aeec1468993ba52badac602c3fe338fe8a82
# first bad commit: [5895f4f01b8896121609b0caa70f362b90772640] source-hash-f90eb33a268bdcd1c52aea5670a58267b0907096

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f90eb33a268bdcd1c52aea5670a58267b0907096

author	Szymon Kłos <eszkadev@gmail.com>	2014-06-28 14:10:39 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2014-06-30 15:31:47 (GMT)
commit	f90eb33a268bdcd1c52aea5670a58267b0907096
tree	cec4d27d19e854d053e937c9a7a84406a0b1fd91
parent	0ee6282cc24af0d299a878f780d1678a86fb0595
DLG_FPICKER_EXPLORERFILE conversion to .ui
Comment 3 Caolán McNamara 2017-10-28 16:42:08 UTC

*** This bug has been marked as a duplicate of bug 74439 ***
Comment 4 Brielle Marshall 2020-05-17 09:45:27 UTC Comment hidden (spam)