Download it now!
Bug 113501 - SVG: Support for missing font glyph not implemented
Summary: SVG: Support for missing font glyph not implemented
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2017-10-28 20:47 UTC by eisa01
Modified: 2019-01-17 12:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
SVG file (9.61 KB, image/svg+xml)
2017-10-28 20:48 UTC, eisa01
Details
Correct rendering in Safari (18.98 KB, image/png)
2017-10-28 20:49 UTC, eisa01
Details
Wrong rendering in LibreOffice (16.34 KB, image/png)
2017-10-28 20:50 UTC, eisa01
Details
how it's displayed in firefox and chrome (17.53 KB, image/png)
2019-01-17 12:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eisa01 2017-10-28 20:47:41 UTC
Description:
SVG is not rendered correctly, it is supposed to be musical notes, but shows up as "W"'s and "&"'s

This is the svg from bug 82221

Note: Firefox also renders this incorrectly, but Safari on Mac does correct

Steps to Reproduce:
Open in Draw or insert in Writer

Actual Results:  
Image is rendered without musical notes

Expected Results:
Image is rendered with musical notes


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38
Comment 1 eisa01 2017-10-28 20:48:20 UTC
Created attachment 137344 [details]
SVG file
Comment 2 eisa01 2017-10-28 20:49:38 UTC
Created attachment 137345 [details]
Correct rendering in Safari
Comment 3 eisa01 2017-10-28 20:50:26 UTC
Created attachment 137346 [details]
Wrong rendering in LibreOffice
Comment 4 Xisco Faulí 2017-10-31 13:16:11 UTC
The notes aren't displayed in Firefox nor Chrome.

it seems like a Safari bug.
Comment 5 eisa01 2017-11-05 14:51:10 UTC
It's not a Safari bug, the Safari rendering is correct.

I had a look at the SVG code.

It uses the "Maestro" font which is not installed on my system. As such it defines missing font glyphs to be used instead. This was part of the SVG standard but has been deprecated removed from SVG 2.0, and support has been removed from Firefox and Chrome.

It's still valid SVG in the 1.1 version, so it's an open question whether LibreOffice should support it. I would say the standard for LibreOffice could be different than web browsers that try to be on the leading edge and rather implement web fonts.

"When SVG was specified, support for web fonts was not widespread in browsers. Since accessing the correct font file is however crucial for rendering text correctly, a font description technology was added to SVG to provide this ability. It was not meant for compatibility with other formats like PostScript or OTF, but rather as a simple means of embedding glyph information into SVG when rendered."

The SVG was created by MakeMusic 2014b.v4722, so you can encounter files with this in the wild.

Some links with more info:
http://caniuse.com/#feat=svg-fonts
https://www.w3.org/TR/SVG/fonts.html#GlyphElement
https://developer.mozilla.org/en-US/docs/Web/SVG/Tutorial/SVG_fonts
Comment 6 Xisco Faulí 2018-11-26 19:16:30 UTC
Dear eisa01,
The svg fiter was replaced by another one.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 eisa01 2018-12-08 08:07:06 UTC
Still present

This should probably be classified as an enhancement
Comment 8 Roman Kuznetsov 2018-12-13 14:45:28 UTC
I tried to open it in Inkscape, Chrome and LO -> all give the same wrong result. But I can't get right result, I don't have Safari.
Comment 9 Xisco Faulí 2019-01-17 12:30:58 UTC
Created attachment 148396 [details]
how it's displayed in firefox and chrome
Comment 10 Xisco Faulí 2019-01-17 12:33:10 UTC
Considering LibreOffice displays it the same way Inkscape, firefox and chrome do it, I will close this issue as RESOLVED WONTFIX. Even if Safari displays it in a different way, it doesn't seem to be the general way this particular file is displayed. 4 vs 1