Bug Hunting Session
Bug 113520 - Split sections inside nested tables: unexpected empty page after editing
Summary: Split sections inside nested tables: unexpected empty page after editing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-30 12:52 UTC by Miklos Vajna
Modified: 2017-10-30 20:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Reproducer document. (27.68 KB, application/vnd.oasis.opendocument.text-flat-xml)
2017-10-30 12:52 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2017-10-30 12:52:21 UTC
Created attachment 137370 [details]
Reproducer document.

Steps to reproduce:

1) Open the attached document.
2) Create a selection from the end of the 1st page to the start of the 3rd page.
3) Press delete.

Actual results: There is an empty 2nd page left after editing.
Expected results: document has only 2 pages.

This one seems to be specific to split sections inside nested tables, i.e. a master-only problem.
Comment 1 Commit Notification 2017-10-30 18:10:57 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c9c956f2716c58e2573a9ac07073f712d736ed02

tdf#113520 sw split sections in tables: avoid empty page after content del

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.