Bug 113558 - Replace 'AutoFormat' button with table style listbox in insert table dialog
Summary: Replace 'AutoFormat' button with table style listbox in insert table dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Furkan Tokac
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Writer-Table-Styles Table-AutoFormat Writer-Table-Insert-Dialog 116091
  Show dependency treegraph
 
Reported: 2017-10-31 19:39 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-03-29 18:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Insert Table dialog optimization proposal (71.90 KB, image/png)
2018-03-01 21:12 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-10-31 19:39:33 UTC
Presently the insert table dialog has a 'AutoFormat' button which opens up the AutoFormat dialog so a user can choose one of the AutoFormat table styles. We should get rid of this button and replace it with a table style listbox or drop down list.
Comment 1 Yousuf Philips (jay) (retired) 2017-10-31 19:40:22 UTC
Heiko, Stuart: so listbox or drop down list for table styles?
Comment 2 V Stuart Foote 2017-10-31 22:21:03 UTC
Would we be adding the "preview" thumbnail into the Insert Table dialog?
Otherwise, the button to launch the Autoformat dialog and show the thumbnail there seems functional.
Comment 3 Heiko Tietze 2017-11-01 09:04:40 UTC
Another well known solution is the preview with left/right buttons to browse through the options.
Comment 4 Yousuf Philips (jay) (retired) 2017-11-01 13:01:15 UTC
(In reply to V Stuart Foote from comment #2)
> Would we be adding the "preview" thumbnail into the Insert Table dialog?

The preview would be possible when another GSoC student comes along and finishes the work on table styles.

> Otherwise, the button to launch the Autoformat dialog and show the thumbnail
> there seems functional.

The problem is that this dialog doesnt apply table styles to the inserted table, it applies autoformat styles to it, so this has to go.
Comment 5 Furkan Tokac 2017-11-22 12:59:43 UTC
Working on it.
Comment 6 Commit Notification 2018-02-28 09:51:52 UTC
Furkan Tokac committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7bf3cf5c9c7f72da0c881b50c2ccc4b6d550af2

tdf#113558: Replace 'AutoFormat' button in insert table dialog.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Furkan Tokac 2018-02-28 21:14:51 UTC
Done.
Comment 8 Commit Notification 2018-03-01 06:09:48 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e0b1e6817f5e727fb0ea1df2f497992365b46b8e

tdf#113558 (related) Update Insert Table dialogs page
Comment 9 Thomas Lendo 2018-03-01 21:12:46 UTC
Created attachment 140278 [details]
Insert Table dialog optimization proposal

Thank you, Furkan and Gabor, for your patches!

I made a draft to optimize the current implementation of the dialog. I suggest:

1. Insert a new "Styles" heading above of the styles selection to separate it visually from the Options section.

2. Shrink the style preview so that it needs only the horizontal half of the dialog.

3. Extend the styles list to the horizontal half of the dialog to give it more room. Now the list looks a little bit densed and some languages have longer names for the table styles that will be cut at the right end like "Simple Grid Columns".
Comment 10 Furkan Tokac 2018-03-02 01:02:09 UTC
(In reply to Thomas Lendo from comment #9)
> Created attachment 140278 [details]
> Insert Table dialog optimization proposal
> 
> Thank you, Furkan and Gabor, for your patches!
> 
> I made a draft to optimize the current implementation of the dialog. I
> suggest:
> 
> 1. Insert a new "Styles" heading above of the styles selection to separate
> it visually from the Options section.
> 
> 2. Shrink the style preview so that it needs only the horizontal half of the
> dialog.
> 
> 3. Extend the styles list to the horizontal half of the dialog to give it
> more room. Now the list looks a little bit densed and some languages have
> longer names for the table styles that will be cut at the right end like
> "Simple Grid Columns".

I'll handle that. Currently, I'm working on tdf#116091 which is same thing, replacing "AutoFormat" button with the preview. I'll apply this recommendations to it and also to this bug.

Mr. Heiko, also you can provide your suggestions so I can apply them too.
Comment 11 Heiko Tietze 2018-03-02 08:21:32 UTC
(In reply to Furkan Tokac from comment #10)
> Mr. Heiko, also you can provide your suggestions so I can apply them too.

Thomas' #2 and #3 should be solved with my tiny modification to your patch in that styles list and preview got an alignment. #1 is a label on top - looks good. 
Alternatively I suggested on Gerrit to layout like this

<    Dimension      > < Preview >
< Style > < Options > 

(The preview has an own column and styles is the initial control for what is listed under options. Meaning, border on/off, color on/off (future enhancement) modifies the chosen style. General options aka dimension on top of that.)
Comment 12 Commit Notification 2018-03-29 18:55:16 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07bb2405a3353a7e75c0d3855b886acbf422013c

tdf#113558 Header missing for table styles

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.