Bug 113567 - UI: vertical scrollbar erratic
Summary: UI: vertical scrollbar erratic
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2017-11-01 11:35 UTC by andy2017
Modified: 2017-11-11 15:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

example spreadsheet that shows the erratic scrollbar behaviour (18.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-01 11:35 UTC, andy2017

Note You need to log in before you can comment on or make changes to this bug.
Description andy2017 2017-11-01 11:35:34 UTC
Created attachment 137415 [details]
example spreadsheet that shows the erratic scrollbar behaviour

With a short spreadsheet of 100 rows or so, the behaviour of the scrollbar is as I'd expect on Windows: clicking either side of the slider moves the spreadsheet one screen up or down. As the number of rows increases, the behaviour starts to get erratic. I've had it go up or down one screen, go up or down multiple screens and sometimes moved the slider (and hence spreadsheet view) to where I clicked in the scroll bar. For a fairly large spreadsheet I've got, it never behaves as I'd expect on Windows.

I've reproduced this behaviour with a sample spreadsheet so that A1 has "date", A2 =today(), A3=A2+1, A4=A3+1 and so on for the number of rows you want to create (I created. The spreadsheet I've attached has 1025 rows. For me, after opening it, when I clicked near the top of scrollbar, it moved one screen up. Clicking again, it moved one screen up. Clicking again, it moved multiple screens up. It seems to be random how many screens it moves up and whether it positions the slider where I clicked in the scroll bar or not.
Comment 1 V Stuart Foote 2017-11-01 12:28:05 UTC
Can not reproduce.

As implemented the slide bar widget does not detect where it has been clicked. A mouse click in the bar is the same as entering the page up/down key. In Calc it will advance height of a "screen" holding the number of rows as visible in the view at the current zoom factor. At 100% zoom it is precise, but with rounding gets a little sloppy when scaling of set from zoom in/out--but still calculating the correct top and bottom row of the screen.

Grabbing the "puck" (with mouse <shift>+click) and sliding it up or down will reposition with one row precision as far as it is dragged. And should display row in the pop-up.

With clean user profile and on a laptop using track pad (or touch screen) this all seems to work consistently and as expected.

Windows 10 Home 64-bit en-US (v1709) with
Version: (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: group
Comment 2 andy2017 2017-11-01 12:44:12 UTC
I'm also using a laptop with trackpad (Dell). I've tried with a clean user profile. With the example spreadsheet zoomed at 100%, I still see the problem: it took 5 clicks last time I tried for the fast scroll to happen (waiting for the previous click to take effect each time). And 9 clicks for it to move to position.

Dragging the slider works as expected. PAGE UP and DOWN work as expected.
Comment 3 Buovjaga 2017-11-10 14:24:47 UTC
Cannot reproduce. Clicked several times.

Version: (x64)
Build ID: 4058d85963e371be657f531d8f30e31381a9ccab
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-05_22:51:05
Locale: fi-FI (fi_FI); Calc: group
Comment 4 andy2017 2017-11-10 17:33:04 UTC
I cannot reproduce with version either.
Comment 5 Buovjaga 2017-11-10 17:41:11 UTC
Andy: Please copy and paste here the contents of your Help - About for both 5.4.2 and 6.0. This allows us to know more about your system.
Comment 6 andy2017 2017-11-10 18:50:35 UTC
I've got them both on the same system and they report the following versions:

Version: (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-GB (en_GB); Calc: group

Version: (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-GB (en_GB); Calc: group
Comment 7 Buovjaga 2017-11-10 19:25:18 UTC
Ok, so both versions have OpenGL turned off, good. It therefore seems version 6.0 contains some fix that makes the problem go away. Are you OK, if we close this report as RESOLVED WORKSFORME?

Here is the release schedule for 6.0: https://wiki.documentfoundation.org/ReleasePlan/6.0

It might also be good to check, if the recently released 5.4.3 contains the same fix.
Comment 8 andy2017 2017-11-10 22:43:42 UTC
I've installed ...

Version: (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-GB (en_GB); Calc: group

... and I've not been able to reproduce this issue either. Thanks for the pointer.
Comment 9 Buovjaga 2017-11-11 14:30:30 UTC
Very nice. Then we can close.
Comment 10 andy2017 2017-11-11 15:55:30 UTC
FWIW screen painting speed has also improved - a lot faster.