Bug 113579 - Recovery Document window shows up when close the PC without closing the LibreOffice instance(s)
Summary: Recovery Document window shows up when close the PC without closing the Libre...
Status: RESOLVED DUPLICATE of bug 32884
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-01 20:11 UTC by Alessandro
Modified: 2019-02-28 10:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Documents Recovery window (13.30 KB, image/jpeg)
2017-12-13 19:11 UTC, Alessandro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro 2017-11-01 20:11:38 UTC
Description:
Hi,

almost all the time I open a Writer document the Recovery function shows up.
I'm sure that I didn't change the document and that I shut down my OS properly.
I used the search function, that's all I did with the document.
Also if I changed the document and shotdown Windows without saving it this Recovery feature is unwanted. The document is not broken, it doesn't need any recovery. I should be asked before closing if I want to save the changes or not, as all the other software do.

This annoying behavior exists from many months so it was not introduced recently.

Windows 10 x64.
LoberOffice 5.2.6.2 (x64)

Kind regards.

Alex




Steps to Reproduce:
1. Open a Writer document.
2. Shut down Windows regularly.
3. Open Windows again and open the same document.

Actual Results:  
The Recovery function shows up sayng the documents needs to be recovered.

Expected Results:
Nothing. The document should open regularly.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.75 Safari/537.36 Maxthon/5.1.3.1000
Comment 1 Dieter 2017-11-02 06:55:45 UTC
Thank you for reporting the bug. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Alessandro 2017-12-01 21:12:43 UTC
The issue is still present with the latest version (5.4.x).

I opened 1 file and I edited them.
I also created a new file.
I probably saved all the changes of both the files (so, no pending changes).

I closed Windows using the dedicated "Power/Shut down" buttons without closing the 2 Writer instances.

After a Windowsa restart when I try to open one Writer document it shows the Document Recovery windows with both the 2 files.
Comment 3 Alessandro 2017-12-13 19:11:48 UTC
Created attachment 138428 [details]
Documents Recovery window
Comment 4 Alessandro 2017-12-13 19:17:06 UTC
Hi,

I started Windows.
I double clicked DocumentAAA.odt.
The Document Recovery window shown up asking me to recover DocumentBBB.odt.
Probably yesterday I used that document but when I closed Windows the program didn't asked me to save the changes (if there were any) so why now I have to recover (recover!) that document? The program broken it itself ?

Libre Office version 5.4 

Regards,

Alex
Comment 5 Buovjaga 2017-12-25 10:36:18 UTC
I confirm this, but forcefully shutting down like that is an abnormal way to close LibreOffice, so I'm not sure if twe should consider this a bug.
Comment 6 Alessandro 2017-12-25 12:55:55 UTC
Closing Windows not caring about running programs is normal for many people.
I just take care of application that atually stop the shout down process.
"Rocovery" a document means it is "compromised" in some way, this is not the case.
Or if it is, the program is creating the problem (= bug).
This "use case" is normal for me, not an abnormal way to shout down LiberOffice.
I have plenty other applications opened, they don't break any document.
(Notepad++ is the best one for this use case because when it restart it also maintain UNSAVED documents. I have unsaved document for months and I continue to edit them !!!)
Comment 7 Dieter 2019-02-28 09:44:22 UTC
(In reply to Buovjaga from comment #5)
> I confirm this, but forcefully shutting down like that is an abnormal way to
> close LibreOffice, so I'm not sure if twe should consider this a bug.

I also can imagine, that a lot of users close LO in this way. So i would consider this as a proposal for an enhancement. Do you agree, Buovjaga?
Comment 8 Buovjaga 2019-02-28 10:49:16 UTC
I found an older one.

*** This bug has been marked as a duplicate of bug 32884 ***