Download it now!
Bug 113779 - Punctuation Marks Are Not In Line With Text for Vertical Orientation in Traditional Chinese
Summary: Punctuation Marks Are Not In Line With Text for Vertical Orientation in Tradi...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: Vertical-Text DOC-Character CJK-Chinese-Traditional
  Show dependency treegraph
 
Reported: 2017-11-12 05:53 UTC by taiwuco
Modified: 2019-06-09 20:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Problematic file (83.50 KB, application/msword)
2017-11-15 14:35 UTC, Buovjaga
Details
PDF export from MSO 2013 (341.85 KB, application/pdf)
2017-11-16 07:01 UTC, Buovjaga
Details
Screenshot showing problems in 3.5 (98.52 KB, image/png)
2017-11-21 17:43 UTC, Buovjaga
Details
Screencast (2.45 MB, video/mp4)
2017-11-23 10:24 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description taiwuco 2017-11-12 05:53:48 UTC
Description:
As in the following document
my.nthu.edu.tw/~purchase/Data/laws/new/4.doc
, the punctuation marks are not in line with text vertically.

Actual Results:  
punctuation marks are not in line with text.

Expected Results:
punctuation marks are in line with text.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Buovjaga 2017-11-15 14:35:41 UTC
Created attachment 137782 [details]
Problematic file
Comment 2 taiwuco 2017-11-15 16:08:35 UTC
As in the video https://www.youtube.com/watch?v=pxKHhObSIY0 , some old version Libreoffice can align punctuation marks with text.
Comment 3 Buovjaga 2017-11-16 07:01:55 UTC
Created attachment 137800 [details]
PDF export from MSO 2013

Confirmed the problem

Win 8.1 32-bit
LibO Version: 6.0.0.0.alpha1+
Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-11-06_23:18:19
Locale: fi-FI (fi_FI); Calc: group
MSO 2013
Comment 4 Buovjaga 2017-11-21 17:43:25 UTC
Created attachment 137896 [details]
Screenshot showing problems in 3.5

This is Windows-only. Linux aligns them OK. This is not a regression as the problem is already in 3.5
Comment 5 taiwuco 2017-11-22 07:56:59 UTC
My environment:
Ubuntu 16.04 AMD64
using the latest Libreoffice: 
http://zh-tw.libreoffice.org/download/libreoffice-fresh/

The problematic file is for your reference. The issue is common.
Comment 6 taiwuco 2017-11-22 08:02:52 UTC
(In reply to Buovjaga from comment #4)
> Created attachment 137896 [details]
> Screenshot showing problems in 3.5
> 
> This is Windows-only. Linux aligns them OK. This is not a regression as the
> problem is already in 3.5

Linux doesn't align at all. My environment is Ubuntu 16.04.03. LibreOffice is the latest version from http://zh-tw.libreoffice.org/download/libreoffice-fresh/
Comment 7 Buovjaga 2017-11-22 08:59:39 UTC
Ok, your initial report was very unclear, so I have had to deduce what could be the problem.

Please attach a similar edited screenshot from Linux like my attachment 137896 [details], circling some example problems.
Comment 8 taiwuco 2017-11-22 15:36:23 UTC
(In reply to Buovjaga from comment #7)
> Ok, your initial report was very unclear, so I have had to deduce what could
> be the problem.
> 
> Please attach a similar edited screenshot from Linux like my attachment
> 137896 [details], circling some example problems.

Thanks. 
I recorded a screencast. I used google drive to share with you.
Comment 9 Buovjaga 2017-11-23 10:22:31 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2017-11-23 10:24:51 UTC
Created attachment 137937 [details]
Screencast

Ok, so you were talking about the parentheses and not the dots.
Comment 11 Anthony Fok 2018-02-02 20:14:13 UTC
Hi taiwuco,

Thank you for filing this bug report!

I was experiencing the same problem with LibreOffice 5.4.x in Debian GNU/Linux (unstable/sid).

However, I have good news!  I upgraded to LibreOffice 6.0.0.3 last night
(with apt, i.e. using .deb package), and Chinese / CJK text in vertical direction is almost perfectly positioned now!

I said "almost" because it seems that certain characters like the CJK full-width comma ",", full-stop "。", or even the character "one" "一" is off-centered, placed a little bit too low.  But yes, that relatively minor issue should be filed in a separate bug (after checking it in Windows and macOS).  But yes, I am very happy now!

So, when you've upgraded to LibreOffice 6 on your Ubuntu, please report back whether the problem is resolved in the new version.

Cheers,
Anthony
Comment 12 Buovjaga 2018-02-02 20:17:53 UTC
Reverting status change as it is not needed in this case. taiwuco can set to RESOLVED WORKSFORME if the problem is gone.
Comment 13 QA Administrators 2019-02-03 04:21:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug