Bug 113840 - [Spreadsheet FORMATTING] Can not remove auto-hyperlink when text within a cell is selected
Summary: [Spreadsheet FORMATTING] Can not remove auto-hyperlink when text within a cel...
Status: RESOLVED DUPLICATE of bug 62561
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2017-11-14 21:14 UTC by Jim Avera
Modified: 2019-08-12 18:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2017-11-14 21:14:04 UTC
Description:
If an email address or other hyperlink is auto-detected in text in a spreadsheet cell, there does not seem to be any documented way to change it back to plain text.  The docs say "...LibreOffice formats the hyperlink with direct font attributes (color and underline) the properties of which are obtained from certain Character Styles." 

1) Those "direct font attributes" are not removed by selecting the text and doing Format->Clear Direct Formatting.   What is a "direct font attribute" which is not "Direct Formatting"?

2) The docs also say you can "open the context menu and choose Remove Hyperlink."
but there is no "Remove Hyperlink" item in the context (right-click) menu when an auto-hyperlink is selected in a spreadsheet cell.   This does work in a text document, however.

Steps to Reproduce:
1. Tools->Autocorrect Options->(Options tab)->URL Recognition checked
2. File->New->Spreadsheet
3. Click in a cell; type "homer@example.com<ENTER>"
4. Select the cell, or select the text inside the cell
5. Format->Clear Direct Formatting
6. right-click to see context menu


Actual Results:  
Clear Direct Formatting does nothting, and there is no
  "Remove Hyperlink" item in the context menu.

Expected Results:
Format->Clear Direct Formatting should clear the "direct font attributes" mentioned in the docs (or if the docs are incorrect then they should be fixed); and the documented "Remove Hyperlink" context menu should be present when the auto-hyperlink is selected.



Reproducible: Always


User Profile Reset: No



Additional Info:

Version: 6.0.0.0.alpha0+
Build ID: cfbb8b5090537e79ba70e250ddee86d53facbe15
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-10-18_22:54:20
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.89 Safari/537.36
Comment 1 Mohamed 2017-11-15 08:45:03 UTC
First I want to confirm that there is no “Remove Hyperlink” option on the context menu. However, other behavior is detected:

1)-Using the mouse cursor the cell containing the link is not easily selected, I should click randomly until selecting. Or I should move using the keyboard arrows.

2)-Once selected the cell:
   a- When performing a right click on the input line the Hyperlink format is removed automatically even without displaying the context menu.  
   b-After selection, go to Format >> Clear Direct Formatting, the format is successfully removed however,
   c-After selection, right click to display context menu you will find “Clear Direct Formatting” option select it and nothing will happen.

Tested on:
    • Operating system: Windows 8.1 Pro 64-bits.
    • LibreOffice: Version: 5.4.3.2 (x64)
      Build ID: 92a7159f7e4af62137622921e809f8546db437e5
      CPU threads: 4; OS: Windows 6.29; UI render: default; 
      Locale: en-US (en_US); Calc: group

And also on:
    • Operating system: Ubuntu 16.04.3 64-bits.
    • LibreOffice :Version: 5.4.3.2
      Build ID: 92a7159f7e4af62137622921e809f8546db437e5
      CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
      Locale: en-US (ja_JP.UTF-8); Calc: group
Comment 2 Aschalew 2017-11-15 09:14:24 UTC
I have tried but the hyperlink can not removed.

Clear Direct formatting doesn't clear the link

windows 10
Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 3 Jim Avera 2017-11-16 01:01:52 UTC
Ok, I confirm that Clear Direct Formatting does remove all hyperlink formatting in a cell if the *cell* is selected. 

However if text within the cell is selected (for example, just one auto-hyperlink of perhaps several), then Clear Direct Formatting has no effect.

(the documented "Remove Hyperlink" context menu item is missing in both cases)


BTW, I also see what Mohamed alluded to about being unable to select a cell with the mouse in certain circumstances; but that's a different bug.
Comment 4 Aschalew 2017-11-16 05:28:54 UTC
Thanks Jim Avera!

Yes, it does remove when I selected a cell. But select only text within a cell Clear Direct Formatting has no effect.
Comment 5 Buovjaga 2017-11-16 13:40:55 UTC
Seems like we should set this to NEW.
Comment 6 Samuel Mehrbrodt (CIB) 2019-08-12 09:13:03 UTC
Looks like a duplicate of bug 62561 which has been fixed meanwhile. Please re-test with a recent master build.

*** This bug has been marked as a duplicate of bug 62561 ***
Comment 7 Jim Avera 2019-08-12 18:25:55 UTC
Confirming that this is fixed in

Version: 6.4.0.0.alpha0+
Build ID: 8387a6db641b29e6ff3c2f4cdc4688f538cbe35f
CPU threads: 12; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-09_06:28:42
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded