Download it now!
Bug 113853 - Traveling with tab in Options -> Aplication colors behaves weird
Summary: Traveling with tab in Options -> Aplication colors behaves weird
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: kirill
URL:
Whiteboard: target:6.2.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2017-11-15 13:30 UTC by Tamás Zolnai
Modified: 2018-08-10 09:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-11-15 13:30:16 UTC
Description:
On Tools -> Options -> Application Colors tab page, when I try to travel through the dialog, it behaves weird. The displayed area of the tab page is different, where the focus actually is.

Steps to Reproduce:
1. Open Tools -> Options -> Applications Colors
2. Try to travel through the tab page with tab

Actual Results:  
Wrong view of the tab page is displayed.

Expected Results:
The actual view always should show the current selection.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.125 Safari/537.36
Comment 1 Tamás Zolnai 2017-11-15 13:31:06 UTC
The source code is here:
cui/source/options/optcolor.cxx
The class SvxColorOptionsTabPage implement this tab page.
Comment 2 Tamás Zolnai 2017-11-15 15:18:26 UTC
Some good notes about widgets:
https://wiki.documentfoundation.org/Development/WidgetLayout
Comment 3 Tamás Zolnai 2017-11-15 15:29:32 UTC
Some more info:
I checked how this optappearancepage.ui can be opened in glade and it seems something is not added to glade catalogue. Anyway the issue seems to be related to m_pColorConfigCT member which is a ColorConfigCtrl_Impl object. So I guess something in ColorConfigCtrl_Impl's implementation is wrong, or I also see GetScrollPosition()\SetScrollPosition() methods of this class which might be called on a wrong way. That's can cause bad scrolling behavior.
Comment 4 Tamás Zolnai 2017-11-15 21:50:52 UTC
I added the missing item into the glade catalog:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=0eb5a4daf0da5658681ec448af5bdbda6ead6455
but glade displayes only an empty block, since the actual items are loaded from code.
Comment 5 Xisco Faulí 2017-12-17 03:28:04 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2018-01-17 03:27:59 UTC Comment hidden (obsolete)
Comment 7 Ekansh Jha 2018-01-28 20:20:35 UTC
(In reply to Tamás Zolnai from comment #0)
> Description:
> On Tools -> Options -> Application Colors tab page, when I try to travel
> through the dialog, it behaves weird. The displayed area of the tab page is
> different, where the focus actually is.
> 
> Steps to Reproduce:
> 1. Open Tools -> Options -> Applications Colors
> 2. Try to travel through the tab page with tab
> 
> Actual Results:  
> Wrong view of the tab page is displayed.
> 
> Expected Results:
> The actual view always should show the current selection.

Could you please explain I didn't get
Comment 8 Tamás Zolnai 2018-01-30 19:33:31 UTC
(In reply to Ekansh Jha from comment #7)
> (In reply to Tamás Zolnai from comment #0)
> > Description:
> > On Tools -> Options -> Application Colors tab page, when I try to travel
> > through the dialog, it behaves weird. The displayed area of the tab page is
> > different, where the focus actually is.
> > 
> > Steps to Reproduce:
> > 1. Open Tools -> Options -> Applications Colors
> > 2. Try to travel through the tab page with tab
> > 
> > Actual Results:  
> > Wrong view of the tab page is displayed.
> > 
> > Expected Results:
> > The actual view always should show the current selection.
> 
> Could you please explain I didn't get

Hi Ekansh Jha,

Try to move the focus with tab inside the tab page. When you moving with tab the different items become selected on the tab page. It is expected that the currently selected item is visible (the view is scrolled to that view). In this case sometimes the item which has the focus is not visible, because scrolling behavior seems not to work correctly.
Comment 9 Ekansh Jha 2018-02-02 21:36:15 UTC
Hi,
Could anyone please review this patch https://gerrit.libreoffice.org/#/c/49104/ .
Comment 10 Xisco Faulí 2018-03-05 03:37:05 UTC Comment hidden (obsolete)
Comment 11 Ekansh Jha 2018-03-05 03:56:26 UTC
(In reply to Xisco Faulí from comment #10)
> A polite ping, still working on this bug?

Yes, I have submitted the patch for review:)
Comment 12 Xisco Faulí 2018-04-05 02:40:39 UTC Comment hidden (obsolete)
Comment 13 Ekansh Jha 2018-04-05 03:56:13 UTC
I am busy right now, might work on this later after this month. If someone is interested can go forward and try it:)
Comment 14 Xisco Faulí 2018-05-06 02:28:36 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2018-06-06 02:44:10 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2018-07-07 02:37:32 UTC Comment hidden (obsolete)
Comment 17 kirill 2018-08-05 22:30:45 UTC
I've pushed the patch. Pls, would somebody review it? https://gerrit.libreoffice.org/#/c/58633/
Comment 18 Commit Notification 2018-08-10 09:52:10 UTC
U-Vladimir\Vadim committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8055f402dbe6783884a51c8a78f4abcf7adda6c4

tdf#113853 fix keeping visible selected items jumping by tab

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.