Download it now!
Bug 113854 - Cross-reference "above" and "below" in Swedish should trade places
Summary: Cross-reference "above" and "below" in Swedish should trade places
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Niklas Johansson
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2017-11-15 13:34 UTC by CK
Modified: 2018-01-20 02:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CK 2017-11-15 13:34:08 UTC
Description:
Using Insert > Cross-reference > Above/Below gives the opposite words in Swedish (sv-SE). 


Steps to Reproduce:
1.Create a "Heading 1"
2. In a paragraph above the heading. Insert>Cross-reference>Above/Below (selecting "Heading 1").
3. In a paragraph below the heading. Insert>Cross-reference>Above/Below (selecting "Heading 1").

Actual Results:  
-Paragraph above heading reads: "ovan" (meaning above).
-Paragraph below heading reads: "nedan" (meaning below).

Expected Results:
-Paragraph above heading should read: "nedan" (meaning below).
-Paragraph below heading should read: "ovan" (meaning above).


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.102 Safari/537.36 Vivaldi/1.93.955.48
Comment 1 Xisco Faulí 2018-01-17 15:32:15 UTC Comment hidden (obsolete)
Comment 2 CK 2018-01-17 15:52:28 UTC
Still present in 5.4.4.2 (flatpak)
Comment 3 Niklas Johansson 2018-01-18 06:17:27 UTC
Thank you for reporting this issue.

I'm pretty sure that the text that you see comes from the file: i18npool/source/localedata/data/sv_SE.xml

      <aboveWord>nedan</aboveWord>
      <belowWord>ovan</belowWord>

... but I need to check how I update that part since I do not find the string in pootle. And also try to find out if there is a reason for the words being switched. Will try to find some time for this next week. Sorry for taking so long.

Niklas
Comment 4 Xisco Faulí 2018-01-18 09:05:34 UTC
Moving to NEW
Comment 5 Niklas Johansson 2018-01-18 17:22:38 UTC
I'll try to fix this as soon as I get my development environment updated.
I'll also try to update any translation of these words that refer to this function so they are always translated into ovan/nedan.

BTW, this seems to be a really old bug. It has been present in all of LibreOffice time and OpenOffice had it this way at least since 2002 when the file was moved to the current location.
Comment 6 CK 2018-01-18 21:23:26 UTC
Interesting it has been around so long.

Just realised now: when I installed 5.4.4.2 as flatpack, maybe it just relied on the existing language pack I had though? Haven't been able to test on a clean system. However, if it currently reads as as cited, then certainly it explains the mixup. 
      <aboveWord>nedan</aboveWord>
      <belowWord>ovan</belowWord>

This would indeed be wrong way around.
Comment 7 Commit Notification 2018-01-20 02:17:34 UTC
sleepingpillow committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab1587fc825080ca9e66edba69021d49407687dd

tdf#113854 - Switch Cross-reference "above" and "below" in Swedish

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.