Bug Hunting Session
Bug 113925 - Paragraph dialog: Doubleclick on ruler should open "tabs" instead of "Indents & Spacing"
Summary: Paragraph dialog: Doubleclick on ruler should open "tabs" instead of "Indents...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Nickson Thanda
URL:
Whiteboard: target:6.1.0
Keywords: regression
Depends on:
Blocks: Paragraph-Dialog Rulers
  Show dependency treegraph
 
Reported: 2017-11-18 21:51 UTC by Christian González
Modified: 2018-04-18 07:09 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian González 2017-11-18 21:51:14 UTC
Description:
A doubleclick in the "ruler" above the text should open the "Tabs" tab, not the "Indents & Spacing" tab.

Steps to Reproduce:
1. Open a Writer document or create a new one
2. double click on the "ruler" above the text, or click on it to create a tab stop, and then doubleclick at that tabstop "L"

Actual Results:  
The "Paragraph" dialog opens, with the "Indents & Spacing" tab open.

Expected Results:
The "Tabs" tab should be the open one, as I am editing tabs here with this doubl click.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
At least we all know this behaviour from MS Word. Maybe there is a good reason why the "wrong" tab opens, and I don't understand it. But it irritates me since many years now... so I'd like to report it here.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Dieter Praas 2017-11-19 09:40:46 UTC
I agree to Christian.
Comment 2 Mike Kaganski 2017-11-19 10:01:49 UTC
And I expect indents and spacing, because ruler is the place where left/right/first line indent is setup.
Comment 3 Christian González 2017-11-19 11:47:28 UTC
No. While this is true for indents, as you named it (first line/indent is set up there too within the ruler), you can already doubleclick on the small handlebars where the e.g. hanging indents are moved per drag&drop - and there you go to the "indents and spaces" tab of the dialog. This works perfectly already.

But if you click *into the ruler* (the free space there) itself, you create a tabulator, and a double click on that (or in the empty space of the ruler) should go to the "tabs" tab.
Comment 4 Thomas Lendo 2017-11-20 12:07:37 UTC
As one click inserts a tab stop and a second click opens the "Indents & Spacing" paragraph dialog tab, it would be more streamlined when it opens the "Tabs" dialog tab.

A double click on the indent ruler point/arrow should open the "Indents & Spacing" paragraph dialog tab.
Comment 5 Dieter Praas 2017-11-26 19:47:56 UTC
I agree with the suggestion of Thomas.
Comment 6 Christian González 2017-11-26 20:06:05 UTC
This was exactly what I supposed. Maybe I did explain it a bit complicated.
Comment 7 Thomas Lendo 2017-11-27 10:58:49 UTC
(In reply to Christian González from comment #6)
> This was exactly what I supposed. Maybe I did explain it a bit complicated.
You explained it in an understandable manner. We only support your idea with new arguments or declare our agreement with your idea. This issue will also be discussed in the next design/UX meeting on Wednesday, 8 pm/20:00 CET.
Comment 8 Heiko Tietze 2017-11-29 20:23:13 UTC
We discussed the proposal in the design meeting. It's a great idea and can be enhanced as clicking outside the margins (gray area) go to the "border" tab (or opens the page dialog instead), inside the margins (white area) shows the "tabs" tab, and clicking the thumbs could open the "indentation".

Ideally, the implementation makes it not too difficult to change the target later.
Comment 9 Mike Kaganski 2018-03-24 21:18:09 UTC
Ah, so this is a regression actually?

Worked as requested in Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

Always starts in Indents and Spacing in Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Became clear with the Nickson Thanda's patch under review at https://gerrit.libreoffice.org/51470

Obviously related to the dialogs conversion to .ui format.
Comment 10 Commit Notification 2018-03-26 07:06:11 UTC
Nickson Thanda committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=42af2f3b2ebd6c559e92e487b9e19ab1e9cd6e33

tdf#113925 doubleclick in ruler opens relevant dialog

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2018-03-26 10:22:32 UTC
Please backport to 6.0. This is not a feature but correction and I find it a good candidate for a backport.
Comment 12 Thomas Lendo 2018-04-18 07:09:09 UTC
Thanks for the work!
The Tabs, Indents & Spacing and the Borders tabs open nicely.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d246aa574571409046619254292698184c2545a3
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-16_02:10:59
Locale: de-AT (de_AT); Calc: CL