Bug Hunting Session
Bug 113933 - Incorrect font rendering with Impress
Summary: Incorrect font rendering with Impress
Status: RESOLVED DUPLICATE of bug 107090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-11-19 15:15 UTC by Gibtnix
Modified: 2017-11-19 20:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gibtnix 2017-11-19 15:15:01 UTC
Hello everyone,

I would like to report a small but pretty annoying error in LibreOffice Impress, appearing in all versions I tested so far, including the latest release. Mainly it is just a "visual" problem, but a really problematic one that mainly forces me to switch to PDF export and PDF presentations.

If you create a small presentation including some text on a slide (even black text on a white slide without anything else reproduces this error), it looks perfectly ok in the editing window. However, as soon as you open the presenter console with hardware acceleration enabled, you see extremely ugly fonts with pretty annoying rendering artifacts. If you disable the hardware acceleration, the fonts will look better, but other things like shapes or included SVG-figures are badly rendered. Interestingly, with enabled hardware acceleration, this included non-text stuff like SVG-figures look great, even embedded fonts in them look perfect. Hence, I only can conclude that there is something going wrong with the rendering of normal text boxes with enabled hardware acceleration. I also would like to emphasize that in editing mode, everything always looks pretty alright, the bug only appears in fullscreen presentation mode. I also tried all kinds of different view and rendering settings (OpenGL etc.), this problem still appears.

Further I'm using a Windows 10 / Linux dual boot configuration, and this issue only appears in the Windows version of LibreOffice. If I switch to Linux (KDE neon LTS), the fonts look perfect with or without hardware acceleration, only disabling it will result in badly rendered SVG-figures. But of course, if I keep the hardware acceleration enabled, everything looks perfect. There is only one small error appearing sometimes depending on the way how SVG-figures are placed closed to text; sometimes I get some artifacts visible as thin white lines "cutting through" the letters of the respective text. I don't know if this is somehow related, but the problem is much more tolerable. Interestingly it does only appear on Linux, not on Windows.

A possible workaround is to use the PDF export and present the slides using a PDF viewer. However I would like to use the presenter console directly to avoid PDF exports (pretty annoying if you want to change something on a slide and always reexport everything).

I also created a topic dealing with this issue in the LO forum; since there has no solution been found, I would like to report this as a bug. Here is the link to my previous question, there is also an example image showing the problem: https://ask.libreoffice.org/en/question/98075/impress-incorrect-font-rendering-in-presentation-mode/

I hope that this can be easily fixed... Thanks in advance! :-)
Comment 1 V Stuart Foote 2017-11-19 19:06:21 UTC
corrected in 5.3.7.2, 5.4.3, and 6.0.0

see https://bugs.documentfoundation.org/show_bug.cgi?id=107090#c27

*** This bug has been marked as a duplicate of bug 107090 ***