Download it now!
Bug 113940 - Draw: EDITING: Resize of blank lines in multi-line text box causes SIGSEGV
Summary: Draw: EDITING: Resize of blank lines in multi-line text box causes SIGSEGV
Status: RESOLVED DUPLICATE of bug 113657
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-11-20 04:21 UTC by James D Howard
Modified: 2017-11-21 16:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB trace of crash with master (30.61 KB, text/plain)
2017-11-20 19:59 UTC, Buovjaga
Details
Example file (99.33 KB, application/vnd.oasis.opendocument.graphics)
2017-11-20 20:00 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James D Howard 2017-11-20 04:21:07 UTC
Description:
An inserted image was selected and text added.  The text was on several lines- "Abc def" <NL> <NL> <NL> "123 456".  The last line selected, text size reduced 4 points. The last 2 <NL> were selected by <Shift><back-arrow>.  Then using the Character... dialog box to change "text" size (i.e. line size), crash occurred upon [ OK ] to do change.  Problem is repeatable.

Steps to Reproduce:
1. Insert image (.jpg in my case); select it
2. Add text to image
3. Change Alignment of text to [Top][Center]
4. Enter multiple line text - line at top with some chars, couple of
   blank lines (hit [Enter] on keyboard a couple of times, type some
   more chars on the last line
5. Select chars on last line and reduce font size a few points; success
6. Move cursor to beginning of this last line
7. Use <Shift><back-arrow> to select under cursor far enough to
   move the cursor back upwards a couple of blank lines
   -- note: I did not back up far enough to reach the chars on
      the 1st (unchanged) line
8. Use [Character...] dialog box to attempt to change size of the
   blank lines downward a couple of points (in my case from 16 to 12)
9. Crash occurs on poke [ OK ] button

Actual Results:  
Application crash

Note: Automatic bugzilla report generation also failed because traceback of Draw could not be successfully generated -- even though 100 "debuginfo files were successfully downloaded.

Expected Results:
First and last lines (with text) move a bit closer together because
the height of the intervening (blank) lines is reduced.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.75 Safari/537.36
Comment 1 Buovjaga 2017-11-20 19:59:47 UTC
Created attachment 137877 [details]
GDB trace of crash with master

I get the crash already at step 8 when opening the dialog.

Arch Linux 64-bit
Version: 6.0.0.0.alpha1+
Build ID: 121303615054568c204def97872343d2014af4a0
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 17th 2017
Comment 2 Buovjaga 2017-11-20 20:00:36 UTC
Created attachment 137878 [details]
Example file

File at step 4.
Comment 3 Xisco Faulí 2017-11-21 16:34:02 UTC
Hi James,
Thanks for reporting the issue.
This should be fixed by https://gerrit.libreoffice.org/#/c/44513/, which is waiting for review. I'll ask developers to review it asap.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 113657 ***