Download it now!
Bug 113941 - Should we change the default fonts used in Writer
Summary: Should we change the default fonts used in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts Writer-UX
  Show dependency treegraph
 
Reported: 2017-11-20 05:24 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-12-01 03:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Word Processor Font Defaults (73.23 KB, application/pdf)
2017-11-20 05:24 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-11-20 05:24:47 UTC
Created attachment 137865 [details]
Word Processor Font Defaults

Writer presently uses Liberation Serif for text and Liberation Sans for headings, which is equivalent to Times New Roman for text and Arial for headings used in Word 2003.

In MSO 2007, Word shifted to using a sans font for text and serif font for headings (the opposite of Word 2003), with the sans font Calibri for text and the serif font Cambria for headings, while Word 2013 began uses Calibri for text and Calibri Light for headings (both sans). Google Docs and iWork Pages also use sans fonts for both text and headings.

Below are defaults used in various word processors and the attachment shows the visual appearances of these defaults.

LibreOffice
Liberation Sans (Arial) 18.2pt for Heading 1
Liberation Serif (Times New Roman) 12pt for Text

MSO 2007/2010
Cambria (Caladea) 14pt for Heading 1
Calibri (Carlito) 11pt for Text

MSO 2013
Calibri Light 16pt for Heading 1
Calibri (Carlito) 11pt for Text

Google Docs
Arial (Liberation Sans) 20pt for Heading 1
Arial (Liberation Sans) 11pt for Text

WordPerfect X7
Times New Roman (Liberation Serif) 18pt for Heading 1
Times New Roman (Liberation Serif) 12pt for Text

iWork Pages 5.6
Helvetica 18pt (Liberation Sans) for Text
Helvetica (Liberation Sans) 11pt for Text
Comment 1 Mike Kaganski 2017-11-20 06:06:53 UTC
What is the problem described in this issue exactly? Do we have a community request? (I don't mean that we *should not* change the defaults; only that we should not simply copy some app's behaviour without a reason.)

The defaults should just enable most users to start working on their documents with minimal effort. If the world population's trend is to prefer sans, then it's OK to comply; so - do we have an evidence?
Comment 2 Heiko Tietze 2017-11-20 08:23:59 UTC
In the comments to the blog post about missing fonts or default table styles, not sure, some replies requested to get rid of serif fonts. Serif is best for printouts, while Sans fits screen reading purpose. Mixing both in one document makes absolutely no sense. So my take is to go with Sans.
That's not a direct reply to Mike's comment 1. 

(The ticket summary is somewhat generic)
Comment 3 Yousuf Philips (jay) (retired) 2017-11-20 13:51:45 UTC
(In reply to Mike Kaganski from comment #1)
> What is the problem described in this issue exactly? Do we have a community
> request? (I don't mean that we *should not* change the defaults; only that
> we should not simply copy some app's behaviour without a reason.)

The request is whether we should change our defaults. Kendy brought up the issue is last week's ESC meeting after asking about the issue in my patch.

https://gerrit.libreoffice.org/#/c/43625/

http://nabble.documentfoundation.org/Libreoffice-qa-minutes-of-ESC-call-td4227222.html

> The defaults should just enable most users to start working on their
> documents with minimal effort. If the world population's trend is to prefer
> sans, then it's OK to comply; so - do we have an evidence?

Yes sans has been the trend the world is going in, as the evidence was provided by the defaults used in other word processors.
Comment 4 Heiko Tietze 2017-11-29 20:19:07 UTC
Proposal was discussed in the design team. Based on the community decision [1] it's a WFM.

https://mobile.twitter.com/liboDesign/status/932556988571181057