Download it now!
Bug 114089 - LibreOffice Base crashes on opening or navigating in forms
Summary: LibreOffice Base crashes on opening or navigating in forms
Status: RESOLVED DUPLICATE of bug 114495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-27 11:38 UTC by Georgi D. Sotirov
Modified: 2018-01-10 11:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId)"]


Attachments
Example SQL script (1.18 KB, text/plain)
2017-11-28 13:05 UTC, Georgi D. Sotirov
Details
Example DB file (50.97 KB, application/vnd.sun.xml.base)
2017-11-28 13:05 UTC, Georgi D. Sotirov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Georgi D. Sotirov 2017-11-27 11:38:36 UTC
Recently released LibreOffice 5.4.3.2 crashes on opening some or navigating in some other forms that I have in a ODB file, which is connected to a MySQL database using MySQL Connector/ODBC 5.3.9 on Windows 7 x64. I'm using this ODB file almost on a daily basis and had no problems with LibreOffice 5.4.2 and the same connector. LibreOffice itself already generated several bug reports the last one of which could be found at http://crashreport.libreoffice.org/stats/crash_details/9c7873bf-7db7-4c1a-bb94-db8222f4eaf9 (from 8 minutes ago). Please, let me know what other information I need to provide and I hope this is fixed soon.
Comment 1 Xisco Faulí 2017-11-27 23:43:13 UTC Comment hidden (obsolete)
Comment 2 Georgi D. Sotirov 2017-11-28 07:40:51 UTC
Should I also provide the related MySQL schema?
Comment 3 Georgi D. Sotirov 2017-11-28 08:06:06 UTC
Strange enough I'm not able to reproduce the issue with a newly defined Data Source used in a new document connecting also with MyODBC 5.3.9, but to a different (example) schema. I noticed that when trying to reconfigure the previously defined Data Source (used by the document that fails) in ODBC Data Source Administrator I get the message "Failure to lookup driver entry at path 'C:\Program Files\MySQL\Connector ODBC 5.3\myodbc5w.dll'". It seems that for some unknown reason the installation path for MySQL ODBC has changed. I'll try to create new data source and use it and would report back whether this solves my problem or not.
Comment 4 Georgi D. Sotirov 2017-11-28 08:23:22 UTC
Unfortunately, defining a new data source and using it in the database document does not solve my problem. I still get the same error in the error report (see newly generated crash report at crashreport.libreoffice.org/stats/crash_details/b149a991-e7df-4184-a79c-f623f1e96aff ). Should I provide the original form that fails, because apparently creating a new one as example is working fine as I reported previously?
Comment 5 Xisco Faulí 2017-11-28 08:30:02 UTC
Hi Georgi,
Yes, please, provide everything needed in order to reproduce the crash.
Comment 6 Georgi D. Sotirov 2017-11-28 13:05:00 UTC
Created attachment 138039 [details]
Example SQL script
Comment 7 Georgi D. Sotirov 2017-11-28 13:05:27 UTC
Created attachment 138040 [details]
Example DB file
Comment 8 Georgi D. Sotirov 2017-11-28 13:10:40 UTC
I have just attached example SQL script for creation of the schema with a single table and a DB file with the original form that fails on navigating through the records of this table (which in reality has about 1200 records). Unfortunately, the problem doesn't reproduce like this and there is no crash on navigating the records, so I'm really not sure how to provide an example that demonstrates the crash. It only seem to happen with my existing DB file. Any clues from the crash report about the nature of the problem, so I could try providing reproducible example?
Comment 9 Georgi D. Sotirov 2017-11-29 12:12:32 UTC
Whatever the reason for the problem I reported in this bug it does not exist in LibreOffice 5.4.2.2 (x64). I just downgraded to this version and everything is fine with the same DB file and same MySQL ODBC Connector without even restarting Windows. How could I contributed further for the identification of the issue given I'm not able to provide reproducible document and not able to share the document I used internally in my organization?
Comment 10 Georgi D. Sotirov 2017-12-07 11:24:17 UTC
Any help anyone?
Comment 11 Xisco Faulí 2018-01-10 11:14:21 UTC
I guess it's a duplicate of bug 114495 and it should be fixed in LibreOffice 6.0 or 5.4

*** This bug has been marked as a duplicate of bug 114495 ***