Download it now!
Bug 114107 - Feature Request: Engineering Notation in LibreOffice Calc under Format Cells
Summary: Feature Request: Engineering Notation in LibreOffice Calc under Format Cells
Status: RESOLVED DUPLICATE of bug 30716
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-28 01:48 UTC by Bruce Fleming
Modified: 2017-11-28 05:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
clip of the format cells dialog Scientific with Engineering notation selected (17.17 KB, image/png)
2017-11-28 05:58 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Fleming 2017-11-28 01:48:13 UTC
Description:
A very useful formatting option in LibreOffice Calc would be to provide engineering notation in addition to the scientific notation already provided.

There is a current similar bug: 77951

Engineering notation is commonly found in use in many fields of science to allow for easy and standardized understanding of units and magnitudes of numbers. It also allows for easy conversion between magnitudes of units.

One very common example is the conversion of units of capacitance in electronics. One of the most commonly used units of capacitance is the micro-Farad, often seen in typed documents as uF. When used on capacitors of small physical size, numbers are often written as 106. This is a 1 followed by a 0 and followed by 6 additional zeroes to make 10,000,000 pF (pico-Farads).

This is only one example of a conversion used very frequently but is found in multitudes of instances every day. Engineering notation makes scientific notation easier to understand, much like metric, using its natural system of magnitudes of 10's, in both whole numbers and real numbers, easier to use.

In short, time saved on converting in the mind by simply seeing what is in a spreadsheet would make things much faster and more useful.

Actual Results:  
Currently using scientific notation or grouping in 1,000's.

Expected Results:
Currently using scientific notation or grouping in 1,000's.


Reproducible: Always


User Profile Reset: No



Additional Info:
Software should provide engineering notation.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Kevin Suo 2017-11-28 03:20:04 UTC
I am setting This valid feather request to NEW.

It would be more helpful if you can provide more technical details (documentations etc) so that the devs can have An idea what Engineering Notation is and what can be expected.
Comment 2 Kevin Suo 2017-11-28 03:26:06 UTC
Just FYI, there is a python library:
https://github.com/slightlynybbled/engineering_notation
Comment 3 V Stuart Foote 2017-11-28 05:56:51 UTC
This was implemented for bug 30716 pending work on ODF 1.3, but with ODF 1.2 Extended, Engineering notation is already in place.

When formatting Scientific, select the "Engineering notation" check box, resulting format code will be 

##0.00E+00

Correctly handling SI the notations is still open as bug 90708

*** This bug has been marked as a duplicate of bug 30716 ***
Comment 4 V Stuart Foote 2017-11-28 05:58:04 UTC
Created attachment 138031 [details]
clip of the format cells dialog Scientific with Engineering notation selected