Bug Hunting Session
Bug 114136 - [Impress] Custom animation does not create or edit the trajectory of movement.
Summary: [Impress] Custom animation does not create or edit the trajectory of movement.
Status: RESOLVED DUPLICATE of bug 53993
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-29 11:38 UTC by gmolleda
Modified: 2017-11-30 15:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2017-11-29 11:38:35 UTC
Description:
You can not create a custom path. If you edit the points of a trajectory, the changes are not executed or saved for another session.
The editing does not allow to create or delete points of the trajectory, and if the existing points are moved from site, then when executing the animation, the original points are still used. Also, if you save, close and reopen, the original path appears and not the modified one, they have not been saved.

Steps to Reproduce:
1.Create object.
2.Select animations
3.Add trajectory.
4.Edit points (not only figure)
5.Move points
6.Exec the animations.

Actual Results:  
The animation exec the old move, and ignore the new positions of the points.

Expected Results:
The animation changes the move to new positions of the points.


Reproducible: Always


User Profile Reset: No



Additional Info:
Not is possible add a custom trajectory, or to allow add and remove points in the editing trajectory.
Spanish help: Para aplicar y modificar un efecto de trayectoria:
Se puede animar un objeto para que se desplace a lo largo de una trayectoria. Puede utilizar las trayectorias predefinidas o crear nuevas.
Si selecciona «Curva», «Polígono» o «Línea a mano alzada», el cuadro de diálogo se cerrará y podrá dibujar la trayectoria. Si finaliza el dibujo sin cancelarlo, la trayectoria creada se elimina del documento y se insertará como un efecto de trayectoria.
Edición de trayectorias
Si el panel Animación personalizada está visible, las trayectorias de todos los objetos de la diapositiva actual se mostrarán como una superposición transparente en la diapositiva. Como todas las trayectorias son visibles todo el tiempo, puede crear fácilmente animaciones con trayectorias consecutivas.
Puede seleccionar una trayectoria si pulsa en ella con el ratón. Las trayectorias seleccionadas pueden redimensionarse y desplazarse como las formas, a través de sus asas. Si se pulsa dos veces en la trayectoria, se activará el modo de edición de puntos. El modo de edición de puntos también puede iniciarse a través del menú Editar ▸ Puntos u oprimiendo F8.

English: https://help.libreoffice.org/Impress/Animating_Objects_in_Presentation_Slides
To apply and edit a motion path effect:

An object can be animated to move along a motion path. You can use predefined or your own motion paths.

If you select "Curve", "Polygon", or "Freeform Line", the dialog closes and you can draw your own path. If the drawing is finished and not canceled, the created path is removed from the document and inserted as a motion path effect.

Editing motion paths

If the Custom Animation Panel is visible, the motion paths of all effects of the current slide are drawn as a transparent overlay on the slide. All paths are visible all the time, therefore animations with consecutive paths can be created easily.

A motion path can be selected by clicking on the path. A selected path will support handles, it can be moved and resized like a shape. A double click on a path starts the point edit mode. The point edit mode can also be started by Edit - Points or by pressing F8.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 gmolleda 2017-11-29 11:53:49 UTC
El inglés me discrimina y por ello lo reescribo en mi idioma materno y en esperanto (un idioma internacional que discrimina menos y respeta más la diversidad cultural y lingüística):
Descripción:
En las animaciones de trayectoria no se puede crear una ruta de movimiento nueva, y las que existen no pueden ser modificadas en sus puntos (sí permite la modificación de la forma pero si editas los puntos verás que no le hace caso ni se guardan los cambios).
Para reproducirlo:
1. Crea una forma y aplica una animación de trayectoria cualquiera.
2. Edita con doble click sobre la trayectoria para que aparezcan los puntos.
3. Mueve varios puntos.
4. Ejecuta la animación y verás que no hace caso a los cambios, la forma se sigue moviendo por la trayectoria original.
5. Si guardas el fichero, cierras LibreOffice Impress y vuelves a abrirlo, verás que la ruta que cambiaste ya no está, se queda la ruta original.

Esperanto:
Priskribo:
En la vivaĵoj de la vojo (trajektorio) vi ne povas krei novan movadon, kaj tiuj, kiuj ekzistas, ne povas esti modifitaj en siaj punktoj (ĝi permesas la modifon de la formo, sed se vi modifas la punktojn, vi vidos, ke ĝi ne atentas ilin aŭ konservas la ŝanĝojn. ).
Provi ĝin:
1. Krei formon kaj apliki vivaĵon de ajna trajektorio.
2. Modifu kun duobla klako sur la trajektorio tiel ke la punktoj aperas.
3. Movu plurajn punktojn.
4. Ekzekutu la novan vivaĵon kaj vi vidos, ke ĝi ne scias la ŝanĝojn, kaj la formo daŭre moviĝas laŭ la origina vojo.
5. Se vi konservos la dosieron, fermu LibreOffice Impress kaj malfermu ĝin denove, vi vidos, ke la vojo (trajektorio), kiun vi ŝanĝis, jam ne plu ekzistas, la origina vojo estas.
Comment 2 Regina Henschel 2017-11-29 18:29:30 UTC
The problem was reported in bug 53993. But I cannot reproduce the error with version Version: 6.1.0.0.alpha0+ (x64)
Build ID: 401a3d2336bf46b38235c498ff86ff675d0de759
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-28_00:13:08
Locale: de-DE (de_DE); Calc: CL

Please try a daily build. The error might be fixed in the meantime. A daily build can be installed parallel to the regular build.
Comment 3 gmolleda 2017-11-30 14:00:33 UTC
I can reproduce that I can't EDIT points of path: You can move a point but the trajectory don't play on new position and impress don't save the changes in positions of points (save, close, open, load impress files and the trajectory is the first).

In 6.0.0.0 beta1 yes is possible create custom paths.
Comment 4 gmolleda 2017-11-30 15:55:45 UTC
This is really a duplicate of 53993
Comment 5 gmolleda 2017-11-30 15:56:12 UTC

*** This bug has been marked as a duplicate of bug 53993 ***