Bug 114138 - Some animations don't work when presenting with hardware acceleration enabled
Summary: Some animations don't work when presenting with hardware acceleration enabled
Status: RESOLVED DUPLICATE of bug 103423
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-11-29 12:51 UTC by Mike Kaganski
Modified: 2017-11-29 16:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A sample presentation which animation fails to play with HW acceleration enabled (13.10 KB, application/vnd.oasis.opendocument.presentation)
2017-11-29 12:51 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2017-11-29 12:51:49 UTC
Created attachment 138063 [details]
A sample presentation which animation fails to play with HW acceleration enabled

Some animations fail to show on presentation screen when hardware acceleration is enabled [1]. This happens on Linux; I couldn't reproduce that on Windows.

An example is in the attachment.

Screencast: http://youtu.be/Kju3_B4eF1Y?hd=1 (it's shown that on dual monitor configuration, the animation plays on Presenter Console fine both with and without acceleration, while on presentation screen, the animation is only visible with acceleration off).

Reproducible with:

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo2
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

and Version: 5.4.3.2
Build ID: 1:5.4.3~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

~$ uname -a
Linux mike-Ubuntu16 4.4.0-98-generic #121-Ubuntu SMP Tue Oct 10 14:24:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Also reported on 5.3.7 and 5.3.6 [1] with following additional info:

"LMDE2 and ALT p8, DE is Trinity, twin WM, X server, OpenGL disabled."

[1] http://forumooo.ru/index.php/topic,6847
Comment 1 Mike Kaganski 2017-11-29 13:26:27 UTC
~/bibisect-42max$ git bisect log
# bad: [8775b1622f226e863b864de7e208226cbfb914e3] source-hash-22ea573b7417db0392c006dff06cde50ddbcd469
# good: [043c0ba8b6968e752e978b33b1cdb6e4d8473a9b] source-hash-c2ccd20c0fd92bddfff76447754541705e3eb8f3
git bisect start 'latest' '043c0ba8b6968e752e978b33b1cdb6e4d8473a9b'
# bad: [6f8d84c92eba22c2c982ed472cf21cb5b208b90d] source-hash-cd30747b74683dc5766073a4a9b3a4c0e5db3723
git bisect bad 6f8d84c92eba22c2c982ed472cf21cb5b208b90d
# good: [f05e4f2814f4659330ce351d50154720d7088f2d] source-hash-228313f32c472da1cb2f7cacf53a25fcd3e12fb3
git bisect good f05e4f2814f4659330ce351d50154720d7088f2d
# good: [b27ced2056139ac365b5a4f1730c3255ee84e124] source-hash-b36fb485d468ddf97076e55ad937caa6331298c0
git bisect good b27ced2056139ac365b5a4f1730c3255ee84e124
# good: [e1852b44573865b2946ecf4be6822ba746ae67b5] source-hash-9b6b03542df7f6b0feecf60a13bab7e885ef3587
git bisect good e1852b44573865b2946ecf4be6822ba746ae67b5
# good: [edd9ab31522111470f997da16da7baf3e0ce95d4] source-hash-ebf5e56e2020359b648b0fec7bd64befe466e4b4
git bisect good edd9ab31522111470f997da16da7baf3e0ce95d4
# good: [45ae0d4e6bdfcdb8ba0d6baed1a8716e0fdde62f] source-hash-29dd94c9aac80d2712957e104ccceb016424e545
git bisect good 45ae0d4e6bdfcdb8ba0d6baed1a8716e0fdde62f
# bad: [c15cdc594005f92c6ecdb91d04b4acdd8095dbe2] source-hash-6ab99e0716091d5387ea3766d6917e580a56b8e4
git bisect bad c15cdc594005f92c6ecdb91d04b4acdd8095dbe2
# good: [f7a7909a5f5aa2ae739cd735aa6685f6de50d755] source-hash-5d87a7f542bd98b1482842596d0aaa4c7757801a
git bisect good f7a7909a5f5aa2ae739cd735aa6685f6de50d755
# good: [31653dbb3567a9e70b8e48a9e844b3419712fc6a] source-hash-7fb73e6c30e66f028fe759376e3789456bf3ad33
git bisect good 31653dbb3567a9e70b8e48a9e844b3419712fc6a
# bad: [eec5bbd91d89bdaa8510f2ce6d37879e4b47506e] source-hash-91fa22fe533588c0e16c705f3810f1ce1a5661a5
git bisect bad eec5bbd91d89bdaa8510f2ce6d37879e4b47506e
# bad: [8a8b50772859fd6198e8e139ca853a4b7aca9133] source-hash-b8002169336b6b7597d32755e41fa3dc2688539e
git bisect bad 8a8b50772859fd6198e8e139ca853a4b7aca9133
# first bad commit: [8a8b50772859fd6198e8e139ca853a4b7aca9133] source-hash-b8002169336b6b7597d32755e41fa3dc2688539e

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b8002169336b6b7597d32755e41fa3dc2688539e

author	Michael Stahl <mstahl@redhat.com>	2013-11-06 15:36:04 (GMT)
committer	Michael Stahl <mstahl@redhat.com>	2013-11-07 20:27:50 (GMT)
commit	b8002169336b6b7597d32755e41fa3dc2688539e
tree	dde6d4ce209e09aa2140575aa1f8386144f76af6
parent	7fb73e6c30e66f028fe759376e3789456bf3ad33
remove INPATH and PROEXT
Comment 2 Michael Stahl (CIB) 2017-11-29 15:32:46 UTC
i don't think that commit can break anything but i've seen it come up before;
this bibisect repo was probably built incrementally, and some
earlier change is responsible but it was masked by the existing
files until this commit moved everything around.

... ah, bug https://bugs.documentfoundation.org/show_bug.cgi?id=103423
is similar, is this a duplicate maybe?
Comment 3 Mike Kaganski 2017-11-29 16:06:49 UTC

*** This bug has been marked as a duplicate of bug 103423 ***