Bug 114139 - FILESAVE XLSX Pie Charts with 3D look get a gray background when saved in Calc and opened in Excel 2013
Summary: FILESAVE XLSX Pie Charts with 3D look get a gray background when saved in Cal...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords: filter:xlsx
: 114183 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-29 15:07 UTC by Gabor Kelemen
Modified: 2018-04-07 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file made with Excel 2013 (18.35 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-29 15:07 UTC, Gabor Kelemen
Details
The example file saved by LO6 alpha (14.31 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-29 15:08 UTC, Gabor Kelemen
Details
Screenshot of the document in LO 6 and Excel 2013 (73.15 KB, image/png)
2017-11-29 15:08 UTC, Gabor Kelemen
Details
Example 3d Chart with background colours, created by MS Excel 2010 (18.67 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-02-07 23:05 UTC, Bartosz
Details
.xlsx file with different chart types (45.57 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-02-08 10:19 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-11-29 15:07:24 UTC
Created attachment 138065 [details]
Example file made with Excel 2013

Pie Charts with 3D look get a gray background when saved in LibreOffice Calc and opened in Microsoft Excel 2013.

Steps to reproduce:
1. Create a new spreadsheet in Microsoft Excel 2013.
2. Create a simple pie chart with 3D look.
3. Save the file as XLSX.
4. Open the file in LibreOffice Calc and save with a different name as XLSX.
5. Open the file created by Calc in Microsoft Excel 2013.

Actual results:
The chart gets a gray background in Microsoft Excel 2013.

Expected results:
The chart should preserve the original white background both in Calc and Excel.
Comment 1 Gabor Kelemen 2017-11-29 15:08:03 UTC
Created attachment 138066 [details]
The example file saved by LO6 alpha
Comment 2 Gabor Kelemen 2017-11-29 15:08:53 UTC
Created attachment 138067 [details]
Screenshot of the document in LO 6 and Excel 2013
Comment 3 Jacques Guilleron 2017-11-30 15:00:26 UTC
Hi Gabor,

Reproduced with
LO 6.0.0.0.beta1 Build ID: 97471ab4eb4db4c487195658631696bb3238656c
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : en-US (fr_FR); Calc: CL
Also with
LO  3.5.3.2 Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
so probably inherited from OOo.
Comment 4 Jacques Guilleron 2017-11-30 16:01:54 UTC
*** Bug 114183 has been marked as a duplicate of this bug. ***
Comment 5 Bartosz 2018-02-07 23:00:01 UTC
The root cause of problem is setting up the shape colour, in chart1.xml file:         
            <c:spPr>
                <a:solidFill>
                    <a:srgbClr val="d9d9d9"/>
                </a:solidFill>
                <a:ln>
                    <a:noFill/>
                </a:ln>
            </c:spPr>
        </c:plotArea>

After replacing it with 
            <c:spPr>
                <a:noFill/>
                <a:ln>
                    <a:noFill/>
                </a:ln>
                <a:effectLst/>
            </c:spPr>

The issue is gone.
Comment 6 Bartosz 2018-02-07 23:01:22 UTC
More information is available at:
http://www.datypic.com/sc/ooxml/e-draw-chart_spPr-1.html
Comment 7 Bartosz 2018-02-07 23:05:00 UTC
Created attachment 139680 [details]
Example 3d Chart with background colours, created by MS Excel 2010
Comment 8 Bartosz 2018-02-07 23:12:34 UTC
It seems that MS Excel is drawing 3D charts differently than LO.
It have two types of colours:
  - for plot area
  - for chart area
Both could have different colours.

As we cannot change "plot area" attributes, the best will be set it as "No fill"
Comment 9 Bartosz 2018-02-08 10:19:01 UTC
Created attachment 139691 [details]
.xlsx file with different chart types
Comment 10 Commit Notification 2018-02-17 18:54:03 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b9e76557d2b5c835a5873de1ce530f36ea98d2d

tdf#114139 Don't export Plot Area shape property fot 3D charts

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-04-07 09:39:21 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dfd19459a336a6cd9a67a0d3dc3cf305de567be1&h=libreoffice-6-0

tdf#114139 Don't export Plot Area shape property fot 3D charts

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.