Download it now!
Bug 114211 - FILESAVE: DOCX: Incorrect gradient rotation after RT
Summary: FILESAVE: DOCX: Incorrect gradient rotation after RT
Status: RESOLVED DUPLICATE of bug 128648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: OOXML-Shapes DOCX
  Show dependency treegraph
 
Reported: 2017-12-02 17:20 UTC by Xisco Faulí
Modified: 2021-01-27 06:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (17.04 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-02 17:20 UTC, Xisco Faulí
Details
comparison LibreOffice 6.1 and MSO 2010 (22.44 KB, image/png)
2017-12-02 17:24 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-12-02 17:20:47 UTC
Created attachment 138180 [details]
sample

Steps to reproduce:
1. Open attached document
2. Save it as .DOCX
3. Open the new .DOCX file

Observed behaviour: Gradients have rotated 180 degrees.

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2618e4a13d719122e6358d9d96864d1691e56a02
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2017-12-02 17:24:21 UTC
Created attachment 138181 [details]
comparison LibreOffice 6.1 and MSO 2010
Comment 2 Xisco Faulí 2017-12-02 17:26:03 UTC
Regression introduced by:

author	Tor Lillqvist <tml@collabora.com>	2014-07-14 20:23:22 +0300
committer	Tor Lillqvist <tml@collabora.com>	2014-07-16 18:21:27 +0300
commit	f4a2f1e647354efb75be8c90384d6cd3e5f9b9bd (patch)
tree	3c444b19805895b9ca37c4614300c1a4a91197b3
parent	9aeadc76a4f2c878f83f07959d9d1694ff13fddf (diff)
bnc#862510: Improve handling of OOXML gradients

Bisected with: bibisect-44max

Adding Cc: to Tor Lillqvist
Comment 3 QA Administrators 2019-09-02 09:21:09 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-09-02 09:24:55 UTC
Still reproducible in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-09-02 09:26:01 UTC
@Miklos Vajna, I thought you might be interested in this issue...
Comment 6 Justin L 2021-01-27 06:03:06 UTC
Every time it is saved, it flips around again. So every second save is "correct".

The explanation in bug 128648 sounds plausible, and is already being worked on. It also suggests that the identified commit just exposed an existing problem.

*** This bug has been marked as a duplicate of bug 128648 ***