Bug Hunting Session
Bug 114386 - Combining character overlaped if it is placed very higher (Doulus SIL Cipher)
Summary: Combining character overlaped if it is placed very higher (Doulus SIL Cipher)
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-12-10 15:36 UTC by Volga
Modified: 2019-10-14 03:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Snapshot (108.99 KB, image/png)
2017-12-10 15:37 UTC, Volga
Details
Snapshot on LibO 6.1.3 (101.80 KB, image/png)
2018-11-28 04:38 UTC, Volga
Details
Snapshot after resizing to page width (82.99 KB, image/png)
2018-11-28 04:41 UTC, Volga
Details
Snapshot on LibO 6.2.4 (90.81 KB, image/png)
2019-05-28 16:53 UTC, Volga
Details
Snapshot on LibO 6.3.1 (82.55 KB, image/png)
2019-09-05 19:52 UTC, Volga
Details
Screenshot of working result (62.89 KB, image/png)
2019-09-06 07:22 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-12-10 15:36:50 UTC
Description:
If a combining placed very higher, the top edge could be overlapped. Reproduce with Doulos SIL Cipher: http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=CipherMusic

Steps to Reproduce:
1. Download DoulosSILCipher-1.020.zip
2. Install DoulosSILCipher-R.ttf
3. Open CipherMusicSample.odt with LO Writer

Actual Results:  
At the first time, Combining Fermata (U+0352) clipped if it placed over number 3 and Combining Dot Above (U+0703), see my attachment. But if I minimize the window into taskbar, then reopen it, the problem is disppeared.

Expected Results:
All the characters sould not be clipped at the first time.


Reproducible: Always


User Profile Reset: No



Additional Info:
版本:5.4.4.1 (x64)
Build ID:da790616461e15a10c95a80eb8ef8ee7b726c114
CPU 线程:4; 操作系统:Windows 6.19; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Volga 2017-12-10 15:37:49 UTC
Created attachment 138345 [details]
Snapshot
Comment 2 Xisco Faulí 2018-11-27 13:25:30 UTC
Hi Volga,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Volga 2018-11-28 04:38:17 UTC
Created attachment 147078 [details]
Snapshot on LibO 6.1.3

OK Xisco, I reproduced again in LO 6.1.3. It still affect me both at the first time and resize the page.

版本:6.1.3.2 (x64)
Build ID:86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group threaded
Comment 4 Volga 2018-11-28 04:41:55 UTC
Created attachment 147079 [details]
Snapshot after resizing to page width
Comment 5 Xisco Faulí 2019-05-28 10:42:31 UTC
Hello Volga,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 Volga 2019-05-28 16:53:12 UTC
Created attachment 151745 [details]
Snapshot on LibO 6.2.4

OK, the problem is still there.

版本: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded
Comment 7 Buovjaga 2019-08-25 09:16:25 UTC
Not reproduced. It might be that a new HarfBuzz fixed the problem.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists with 6.4. Change to RESOLVED WORKSFORME, if the problem went away.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 8 Volga 2019-09-05 19:52:56 UTC
Created attachment 153937 [details]
Snapshot on LibO 6.3.1

Oh well, I can still reproduced in
版本: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded
when I opened this file.
Comment 9 QA Administrators 2019-09-06 05:02:38 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2019-09-06 07:22:14 UTC
Created attachment 153975 [details]
Screenshot of working result
Comment 11 bradly 2019-10-14 03:24:01 UTC Comment hidden (spam)