Download it now!
Bug 114412 - LibreOffice won't open files on a network drive with just a click in file explorer from a cold start
Summary: LibreOffice won't open files on a network drive with just a click in file exp...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2017-12-11 20:21 UTC by craig@arno.com
Modified: 2018-01-29 23:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description craig@arno.com 2017-12-11 20:21:53 UTC
Description:
When I click on a file in File Explorer or a Shortcut on my desktop for a file located on a networked drive I get the message "P:\Documents\Finances\Budget2017.ods does not exist." iff a LibreOffice instance is -not- already running.

If I start LibreOffice (create an instance), then click on the the file/shortcut, while an instance of LO is running, then the application (in this case a spreadsheet) will open as expected.

This looks like an LO network file load driver dependency problem.

Windows 10 OS (Surfacebook), LibreOffice 5.4.3.2 x64, Network drive-Ubuntu 16.04 LTS x64 Linux 4.4.0-101-generic, smbd -V: Version 4.3.11-Ubuntu

I am an experienced user of Windows/Linux and LibreOffice.

Steps to Reproduce:
1. Make sure all instances of LO are closed/not running, including any "auto-start" instances.
2. Double click on a network drive LO file to open for editing (in file explorer)
3. Observe the error

Actual Results:  
"P:\Documents\Finances\Budget2017.ods does not exist."  (When in fact the file does exist and is available)

Expected Results:
Expect that all software dependencies for opening a network share file are loaded/resolved before LO tries to open a file on a network shared drive, thus allowing the network shared file to be opened, from a LO "cold start".


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
---------------------
Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group



User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2018-01-29 17:43:33 UTC Comment hidden (obsolete)
Comment 2 craig@arno.com 2018-01-29 19:04:55 UTC
Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group


This version appears to work correctly with a shortcut to a network drive location when cold starting LibreOffice (no current running instance of LibreOffice).
Comment 3 Xisco Faulí 2018-01-29 23:43:02 UTC
Closing as RESOLVED WORKSFORME then.
Thanks for retesting.