Bug Hunting Session
Bug 114468 - macOS: 15 sec maximum CPU utilization for a search in expert configuration menu with a limited input
Summary: macOS: 15 sec maximum CPU utilization for a search in expert configuration me...
Status: RESOLVED DUPLICATE of bug 114462
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2017-12-14 14:51 UTC by Telesto
Modified: 2018-03-08 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-12-14 14:51:41 UTC
Description:
MacOS: 15 sec maximum CPU utilization for a search in expert configuration menu with a limited input. It's similar to bug 114462, but takes way longer on MacOS

Steps to Reproduce:
1. Launch LibreOffice  6.1 alpha with Instrument using the time profile
2. Open LibreOffice
3. Tools -> Options -> Advanced
4. Click Open Export Configuration
5. A small search term: 'A'  -> Enter



Actual Results:  
Slow search, high CPU utilization

Expected Results:
Fast search, low CPU utilization


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: d46dc8e547810208287aab77f0313f1971901464
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-12-08_10:35:46
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8
Comment 1 Alex Thurgood 2017-12-15 07:24:26 UTC
It certainly occupies one processor at 100% for a while.

Testing with

Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
Threads CPU : 8; OS : Mac OS X 10.13.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Searching for a single character :

'E' : 12 seconds
'F' : 11 seconds
Comment 2 Tor Lillqvist 2018-01-04 12:48:06 UTC
This is surely not Mac-specific? I see similar slowness on Linux, too, in master.
Comment 3 Tor Lillqvist 2018-01-04 15:15:37 UTC
On the other hand, why would a user search for all entries matching a single character? That is a very unlikely thing to do. If you instead search for something meaningful (with less matches), it will take much less time. What is the actual plausible end-user scenario here?
Comment 4 Telesto 2018-01-04 17:09:09 UTC
(In reply to Tor Lillqvist from comment #3)
> On the other hand, why would a user search for all entries matching a single
> character? That is a very unlikely thing to do. If you instead search for
> something meaningful (with less matches), it will take much less time. What
> is the actual plausible end-user scenario here?

I mostly go for an easy extreme illustration (which makes the point clear) and expect it to be in a real life user case to.. Anyway: a few more realistic search terms: "Office", "OpenOffice" "Text" "Windowstate", or "Font". 

Btw, the problem is isn't mac only

Most end-user don't use the expert configuration.. so the importance is probably low.. Especially when the code isn't reused somewhere
Comment 5 Xisco Faulí 2018-03-08 13:36:01 UTC
*** Bug 114462 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2018-03-08 13:36:50 UTC
Probably the root cause is the same as in bug 114462

*** This bug has been marked as a duplicate of bug 114462 ***