Bug Hunting Session
Bug 114507 - LibreOffice only starts as root, if OpenCL is enabled
Summary: LibreOffice only starts as root, if OpenCL is enabled
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2017-12-17 02:08 UTC by Manuel Garcia Wolff
Modified: 2019-06-27 02:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
diff user profile (left) and root profile (right) (30.25 KB, text/plain)
2017-12-17 15:31 UTC, Manuel Garcia Wolff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Garcia Wolff 2017-12-17 02:08:17 UTC
Description:
I downloaded LibreOffice_5.4.3_Linux_x86-64_rpm.tar.gz and tried to run LibreOffice. However, it only start as root. When starting those applications as a user, libreoffice hangs after the splash screen, before any window opens. No messages are displayed in the console. 

I tried removing ~/.config/libreoffice and I also tried "chmod -R 777 ~/.config/libreoffice", but it did not help.

The only valid work around I found was copying the /root/.config/libreoffice folder to my user's home and making the user the owner of that folder. Afterwards, libreoffice started successfully.

Steps to Reproduce:
1. Try to start LibreOffice:
$ /opt/libreoffice5.4/program/soffice


Actual Results:  
LibreOffice never starts.

Expected Results:
LibreOffice should start.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
LibreOffice starts fine as root.

$ vglxinfo | grep OpenG
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.3.0
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.3.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:



User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Julien Nabet 2017-12-17 10:05:52 UTC
These builds are more for packagers who know how to deal with config/dependencies.
BTW, you shouldn't launch LO from root.
Please a give a try to a package provided by your distribution.
Comment 2 Manuel Garcia Wolff 2017-12-17 15:01:09 UTC
I tried my distribution's (Gentoo) installation method before trying the package from the LibreOffice website. I had the same problem with both the Gentoo source installation and the Gentoo binary package. See also: https://bugs.gentoo.org/show_bug.cgi?id=641404

I do not start LibreOffice as root. My workaround is to copy root's ~/.config/libreoffice folder to the user's ~/.config folder.
Comment 3 Julien Nabet 2017-12-17 15:08:30 UTC
It could be interesting to run a diff -r between root LO profile and user LO profile.
Here are some information about user profile https://wiki.documentfoundation.org/UserProfile
The main file is registrymodifications.xcu
Before comparing registrymodifications.xcu, a xml reformat may be useful.
Comment 4 Manuel Garcia Wolff 2017-12-17 15:31:03 UTC
Created attachment 138490 [details]
diff user profile (left) and root profile (right)
Comment 5 Manuel Garcia Wolff 2017-12-17 15:37:01 UTC
I removed the user's ~/.config/libreoffice profile folder and created a new one. Then, I ran a diff between the working profile folder and the broken profile folder. Please find the full diff attached. 
When I replaced my new "registrymodifications.xcu" file with the one from the root profile, I could start LibreOffice successfully as a user. I manually copied lines from root's registrymodifications.xcu to my user's file, until I found the line that allows to start LibreOffice:

==
<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="UseOpenCL" oor:op="fuse"><value>false</value></prop></item>
==
Comment 6 Julien Nabet 2017-12-17 15:41:33 UTC
Great!
So as indicated in https://wiki.documentfoundation.org/QA/FirstSteps#Computation-related_issues_in_Calc_.28OpenCL.29, attach "locate <user profile>/cache/opencl_devices.log and opencl_profile.xml, and attach them to the bug report (these files are created since version 5.1.4). This will help the development team assess whether the issue could be with the OpenCL implementation in your system, or within LibreOffice"
Comment 7 Manuel Garcia Wolff 2017-12-17 17:53:09 UTC
I do not have those files in my ~/.config/libreoffice folder, non any file whose name starts with "opencl".
Comment 8 Manuel Garcia Wolff 2017-12-17 17:54:04 UTC
Those files are not present in the /root/.config/libreoffice either.
Comment 9 Julien Nabet 2017-12-17 18:47:13 UTC
Ok, thought these files would be present.

I can't help more here but certainly some people will be able to.
Comment 10 Manuel Garcia Wolff 2017-12-17 19:22:36 UTC
Thank you!
Comment 11 Xisco Faulí 2018-11-27 13:37:54 UTC
Hello  Manuel Garcia Wolff,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 12 QA Administrators 2019-05-27 02:46:23 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2019-06-27 02:55:15 UTC
Dear Manuel Garcia Wolff,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp