Bug 114510 - Increased character spacing AND ligatures → faulty justification, caret positioning etc.
Summary: Increased character spacing AND ligatures → faulty justification, caret posit...
Status: RESOLVED DUPLICATE of bug 105913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-17 11:54 UTC by j_mach_wust
Modified: 2018-04-27 03:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example paragraphs with _iifiii_.odt (15.57 KB, application/vnd.oasis.opendocument.text)
2017-12-17 11:55 UTC, j_mach_wust
Details
example paragraphs with _iifiii_.png (Screenshot) (922.55 KB, image/png)
2017-12-17 11:55 UTC, j_mach_wust
Details

Note You need to log in before you can comment on or make changes to this bug.
Description j_mach_wust 2017-12-17 11:54:13 UTC
Description:
Text that has both increased character spacing and ligatures will have faulty justification, caret positioning, spell-check underlining etc.

Basically, justification, caret positioning or spell-check underlining behave as if the text had no ligatures. This looks to me as if all these operations were applied before the ligatures when it should really be the other way around.

Steps to Reproduce:
1. Type text with potential ligatures (like "fi" etc.)
2. Choose a font with these ligatures (e.g. "FreeSerif" or "Linux Libertine").
3. Increase character spacing ("Character..." dialog, "Position" tab, positive value in "Spacing", e.g. "5.0 pt")
4. Make sure that the ligatures are still displayed if necessary (e.g. by using a zero-width joiner or by explicitly setting "FreeSerif:liga=1")

Actual Results:  
After a word with a ligature, things are positioned further right as if the word had not been shortened by the ligature:
* The caret is further right than where new characters are typed.
* Line justification will cut off the line before it reaches full width.
* Spell-check underlinings are shifted right and take up more place than the word length.

Expected Results:
* The caret should be where new characters are typed.
* Line justification should reach full line width.
* Spell-check underlinings should be under the word.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This bug is not about the default behaviour of ligatures when character spacing is increased. Whether or not increasing the character spacing disables ligatures (as it should, see bug 93033), we can still choose to have increased character spacing with ligatures, e.g. by setting "liga=1" or by using a zero-width joiner.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 j_mach_wust 2017-12-17 11:55:18 UTC
Created attachment 138485 [details]
example paragraphs with _iifiii_.odt
Comment 2 j_mach_wust 2017-12-17 11:55:55 UTC
Created attachment 138486 [details]
example paragraphs with _iifiii_.png (Screenshot)
Comment 3 V Stuart Foote 2017-12-18 01:55:27 UTC
Confirmed on Windows 10 Home 64-bit en-US with
Version: 5.4.4.1 (x64)
Build ID: da790616461e15a10c95a80eb8ef8ee7b726c114
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: group

and with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77adb770164fd703a31d8e828d777a4f827a5407
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-17_03:10:29
Locale: en-US (en_US); Calc: group threaded

Toggle the Control Markings (<Ctrl>+F10) active. In paragraphs with liga=1 set, while text is composed with the ligatures--the word boudry markings, and the misspelling markings as noted, are not adjusted to match text layout.
Comment 4 Khaled Hosny 2018-04-27 03:19:51 UTC

*** This bug has been marked as a duplicate of bug 105913 ***