Bug Hunting Session
Bug 114516 - Selecting Date in sidebar number format dropdown disables cell input on double click
Summary: Selecting Date in sidebar number format dropdown disables cell input on doubl...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Properties-Number-Format
  Show dependency treegraph
 
Reported: 2017-12-17 21:49 UTC by Jim Raykowski
Modified: 2018-12-29 10:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Raykowski 2017-12-17 21:49:24 UTC
Here are the steps to reproduce this bug

1. enter 12345 in a Calc cell
2. single click on a different cell to change focus
3. double click on cell in step 1
4. select 'Date' from sidebar 'Select a category of contents' dropdown in the Properties deck Number Format panel

cell input/edit mode ends and date is shown in cell

5.double click on any other cells.

cells do not change to edit mode with cursor flashing in cell.

6. press Esc key
7. double click on any cells.

cursor flashes in cells and edit works.
Comment 1 Jacques Guilleron 2017-12-17 23:14:21 UTC
Hi Jim,

I don't reproduce with
LO 6.1.0.0.alpha0+ Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-02_23:45:34
Locale: fr-FR (fr_FR); Calc: CL

Can you precise your OS?
Thank you.
Comment 2 Jim Raykowski 2017-12-17 23:26:32 UTC
Jacques,

Version: 6.1.0.0.alpha0+
Build ID: 77adb770164fd703a31d8e828d777a4f827a5407
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

also

Version: 5.4.3.2
Build ID: 1:5.4.3~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2;
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Jacques Guilleron 2017-12-18 00:54:50 UTC
Thank you for the infos.
I set back to Unconfirmed.
Comment 4 Buovjaga 2017-12-25 19:15:17 UTC
Repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 3272525e6b47af30ea5d92571cd7a6214117d359
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on December 25th 2017
Comment 5 QA Administrators 2018-12-26 03:41:01 UTC Comment hidden (obsolete)
Comment 6 Jim Raykowski 2018-12-29 10:06:01 UTC
Works for me with

Version: 6.3.0.0.alpha0+
Build ID: 33b25ba9692c3ef389fe0ac5883d2659140f85a6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded