Download it now!
Bug 114649 - DOCX: Text Higlight problem with bulleted or numbered lists
Summary: DOCX: Text Higlight problem with bulleted or numbered lists
Status: RESOLVED DUPLICATE of bug 106991
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-12-22 12:47 UTC by E.K
Modified: 2018-02-01 16:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bulleted_and_numbered_texts_problem (1.06 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-22 12:47 UTC, E.K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E.K 2017-12-22 12:47:30 UTC
Created attachment 138594 [details]
bulleted_and_numbered_texts_problem

When using docx format and if the document edited in different computers using libreoffice ; and when you want to highlight a part or complete list bullets or numbers backgroud get painted. after that
changing the highlight color won't refresh the bullets/numbers, they stay the color of first highlight color. and if you make a new line to add more dots or numbers the line you were at and the new line's highlight color reset to no color.
In normal operation bullets and numbers don't be affected by the highlight command.

In the scenario with the document attached. (Read the steps and look at the document and screenshot inside it)

I had a docx file created in Windows/MicrosoftOffice
I edited the document using LibreOffice 6.0.0.1 Writer on Ubuntu17.10(xorg). (No problem yet)
I sent the document to a windows machine and edited it using LibreOffice 6.0.0.1 Writer. (Problem appears here as stated above)
I send the document back to Ubuntu machine and open the document. Problem stays. 

In short while using  docx documents and sending back and forth to windows machine and linux machine, highligting the bulleted or numbered lists won't works as expected.
Comment 1 Dieter 2017-12-22 20:31:30 UTC
> I had a docx file created in Windows/MicrosoftOffice
> I edited the document using LibreOffice 6.0.0.1 Writer on Ubuntu17.10(xorg).
> (No problem yet)
> I sent the document to a windows machine

It's not clear to me: Do you send it as docx or as odt?

> and edited it using LibreOffice
> 6.0.0.1 Writer. (Problem appears here as stated above)
> I send the document back to Ubuntu machine

It's not clear to me: Do you send it as docx or as odt?
Comment 2 E.K 2017-12-22 21:07:35 UTC
all parts in docx format. I didn't convert it to the odt format. Opened in docx format, edited and saved as docx.
Comment 3 Dieter 2017-12-22 21:58:21 UTC
Why don't you use odt-format after you edited it the first time? Can you try it? Does it solve your problem?
Comment 4 Buovjaga 2017-12-26 17:46:16 UTC
(In reply to E.K from comment #0)
> I had a docx file created in Windows/MicrosoftOffice

Can you please attach this original file?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 5 Gabor Kelemen 2018-02-01 16:10:03 UTC

*** This bug has been marked as a duplicate of bug 106991 ***