Bug Hunting Session
Bug 114767 - EDITING - Calc slows down then freezes when a few cells are selected
Summary: EDITING - Calc slows down then freezes when a few cells are selected
Status: RESOLVED DUPLICATE of bug 121860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-30 09:03 UTC by Alda
Modified: 2019-02-18 12:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Spiking processor from selecting non-adjacent cells in Calc (123.97 KB, image/png)
2018-05-10 15:13 UTC, E Moen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alda 2017-12-30 09:03:32 UTC
Description:
When a sufficient amount of cells (6 on an old laptop, ~20 on a recent one) are selected in 5.4.4.2 there is an increasing delay when selecting new cells until Calc freezes.

It happens with or without OpenCL enabled.

I can't reproduce it with 6.0.0-rc1.

Steps to Reproduce:
- Open a new spreadsheet in calc.
- Hold CTRL
- Click on empty non-adjacent cells to select them. The slowdown happens around 20 cells selected.

Actual Results:  
Calc slows down and freeze

Expected Results:
The selection of new cells should not freeze Calc.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 5.4.4.2
Build ID: 5.4.4-1
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL : gtk3; 
Locale : fr-FR (fr_FR.utf8); Calc: CL


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Xavier Van Wijmeersch 2017-12-30 13:37:12 UTC
no repro

Version: 5.4.5.0.0+
Build ID: a61f45499856aad9910d82af1312a163504c15c2
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 2 Jean-Baptiste Faure 2017-12-30 16:34:08 UTC
Reproducible with LO 5.4.4. from Ubuntu PPA and 6.0.0.1.0+ built at home under Ubuntu 16.04 x86-64 : after about 20 selected cells, it take several seconds for each additional selection.

Version: 5.4.4.2
Build ID: 1:5.4.4~rc2-0ubuntu0.16.04.1~lo1
Threads CPU : 4; OS : Linux 4.4; UI Render : GL; VCL : gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: single

Version: 6.0.0.1.0+
Build ID: 58329573e6d58b2f9b9d049b2bdc79e6a3c089f0
Threads CPU : 4; OS : Linux 4.4; UI Render : GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

Same behavior for 6.0.0.1.0+ if not threaded.

Best regards. JBF
Comment 3 E Moen 2018-05-10 15:13:59 UTC
Created attachment 142018 [details]
Spiking processor from selecting non-adjacent cells in Calc
Comment 4 E Moen 2018-05-10 15:17:30 UTC
Confirmed on:
Versie: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU-threads: 4; Besturingssysteem: Linux 4.15; UI-render: standaard; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group

I noticed two things:

1. The speed of selecting the non-adjacent cells (with CTRL) makes a difference. When selecting very fast, Calc cannot follow the process after about 5 cells. When selecting slow, it an take up to about 25 cells before the extreme slow down starts.

2. One processor thread spikes when this happens. See the screen-region picture I added.
Comment 5 Buovjaga 2019-02-18 12:03:45 UTC
Duping to a newer one as it has more data/testing info.

*** This bug has been marked as a duplicate of bug 121860 ***