Bug 114776 - After sum() is executed, the result is not correct
Summary: After sum() is executed, the result is not correct
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-31 00:04 UTC by shigekiuno
Modified: 2018-03-01 14:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
correct calculation off sum (9.96 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-12-31 06:56 UTC, Xavier Van Wijmeersch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shigekiuno 2017-12-31 00:04:43 UTC
Description:
sum()'s result is not correct...

Steps to Reproduce:
sum total (sum()) is not correct

 24,092
 24,092
 24,092
 34,892
 34,892
 13,292
 13,292
 10,800
 24,092
 10,800
 21,600
 34,892
 24,092
 24,092
 24,092
  2,492
 10,800
 10,800
 10,800
--------
=sum()  


Actual Results:  
367,200

Expected Results:
367,196


Reproducible: Always


User Profile Reset: No



Additional Info:
I performed the same on Google spreadsheet, the result is 367,196. And also calculate with calculator, the result is 367,196.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36
Comment 1 Terrence Enger 2017-12-31 01:41:17 UTC
I wonder if there might be a hidden cell in the range you are summing?

If that is not the case, can you please send us a spreadsheet showing the problem?  Remember that your submission will be visible to the whole world.

I am setting bug status NEEDINFO.  When you respond, please set the status back to UNCONFIRMED.

Thank you,
Terry.
Comment 2 Xavier Van Wijmeersch 2017-12-31 06:54:59 UTC
I calculated with a spreadsheet and calculator and my sum is 377,996.
My opinion you mist on 10,800, that's the difference 377,996 and 367,196.
I think its not a bug and my i suggest to upgrade your LO to still version.
Comment 3 Xavier Van Wijmeersch 2017-12-31 06:56:06 UTC
Created attachment 138759 [details]
correct calculation off sum
Comment 4 Kevin Suo 2018-03-01 14:21:02 UTC
I guess when you encounter this bug, some cell contents in your spreadsheet are actually "text", not "numbers". This can be observed when you set the cell alignment to default. The values in "text" format are aligning left.

If a value is "text", you can see there is a "'" before the number.